busybox: let buildroot handle stripping
authorMike Frysinger <vapier@gentoo.org>
Mon, 10 Jan 2011 14:28:40 +0000 (09:28 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 11 Jan 2011 09:50:13 +0000 (10:50 +0100)
For some ABI's (like FLAT), we cannot strip busybox as the file format
does not support it and strip will abort with errors like 'File format
not recognized'.  Since the toplevel already takes care of stripping
things, simply disable the busybox step.

Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk

index 342819a8f89a23a834927d257bd593d3e98162ff..38897f797cd3182f2a3a39de93bb801cdfed8340 100644 (file)
@@ -21,7 +21,8 @@ BUSYBOX_MAKE_OPTS = \
        PREFIX="$(TARGET_DIR)" \
        EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
        CROSS_COMPILE="$(TARGET_CROSS)" \
-       CONFIG_PREFIX="$(TARGET_DIR)"
+       CONFIG_PREFIX="$(TARGET_DIR)" \
+       SKIP_STRIP=y
 
 ifndef BUSYBOX_CONFIG_FILE
        BUSYBOX_CONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG))