package/python-iniparse: bump to version 0.5
authorTitouan Christophe <titouan.christophe@railnova.eu>
Wed, 5 Feb 2020 14:11:47 +0000 (15:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 5 Feb 2020 14:48:22 +0000 (15:48 +0100)
This version brings Python 3.x support, so we make the package
available with Python 3.x. Also, iniparse now requires six, which has
been detected thanks to the runtime tests.

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
[Thomas: drop depends on python || python3]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-iniparse/Config.in
package/python-iniparse/python-iniparse.hash
package/python-iniparse/python-iniparse.mk

index 65c1064927ebd5451d27eeaa3d4ef5d3b9a1eeb8..3d9c02e4cb29ed8d54e094cbfab61cfc9e9d080e 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_PYTHON_INIPARSE
        bool "python-iniparse"
-       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON_SIX # runtime
        help
          iniparse is an INI parser for Python which is API compatible
          with the standard library's ConfigParser, preserves
index b8430255217252fb41038ad71ce1cea420299dbc..238d41e06dd6e823f018c84f4d4ff63554ee52d0 100644 (file)
@@ -1,7 +1,7 @@
-# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=5e573e9e9733d97623881ce9bbe5eca6
-md5 5e573e9e9733d97623881ce9bbe5eca6 iniparse-0.4.tar.gz
+# From https://pypi.org/project/iniparse/#copy-hash-modal-5fdd923b-0592-4d2d-8b49-03472f948290
+md5 2054bab923df21107652d009f2373789 iniparse-0.5.tar.gz
+sha256  932e5239d526e7acb504017bb707be67019ac428a6932368e6851691093aa842  iniparse-0.5.tar.gz
 
 # sha256 locally computed
-sha256  abc1ee12d2cfb2506109072d6c21e40b6c75a3fe90a9c924327d80bc0d99c054  iniparse-0.4.tar.gz
 sha256  ff45637d8a96adc414179e502fbed40160e57205bf2e302140e79a0c71eceaa7  LICENSE
 sha256  9b02e3dfe433ccd2bd94636ef6eb08638b5a54deafe5f87a3d9d9104356c48e0  LICENSE-PSF
index 5c4e03c88c252c19b4f64375f98b35c97b44524b..d31a490bd8928ca7e4d74c55e20ac1a054bb47d5 100644 (file)
@@ -4,11 +4,11 @@
 #
 ################################################################################
 
-PYTHON_INIPARSE_VERSION = 0.4
+PYTHON_INIPARSE_VERSION = 0.5
 PYTHON_INIPARSE_SOURCE = iniparse-$(PYTHON_INIPARSE_VERSION).tar.gz
 PYTHON_INIPARSE_SITE = https://pypi.python.org/packages/source/i/iniparse
 PYTHON_INIPARSE_LICENSE = Python-2.0, MIT
 PYTHON_INIPARSE_LICENSE_FILES = LICENSE-PSF LICENSE
-PYTHON_INIPARSE_SETUP_TYPE = distutils
+PYTHON_INIPARSE_SETUP_TYPE = setuptools
 
 $(eval $(python-package))