mxml: bump version to 2.7
authorBaruch Siach <baruch@tkos.co.il>
Tue, 15 May 2012 18:38:02 +0000 (18:38 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 16 May 2012 05:36:30 +0000 (07:36 +0200)
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/mxml/mxml-2.6-fix-cross-target-installation.patch [deleted file]
package/mxml/mxml-fix-cross-target-installation.patch [new file with mode: 0644]
package/mxml/mxml.mk

diff --git a/package/mxml/mxml-2.6-fix-cross-target-installation.patch b/package/mxml/mxml-2.6-fix-cross-target-installation.patch
deleted file mode 100644 (file)
index 62b6bbc..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Baruch Siach <baruch@tkos.co.il>
-Subject: [PATCH] mxml: workaround for cross build
-
-The added patch is a workaround for cross build as follows:
-
-       * disable run of a test binary at build time
-       * disable generation of documentation using the mxmldoc binary
-       * remove now non-existent entries from the install target
-       * disable strip when running install
-
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
-diff -Nuar mxml-2.6-dist//Makefile.in mxml-2.6/Makefile.in
---- mxml-2.6-dist//Makefile.in 2008-12-06 06:20:38.000000000 +0200
-+++ mxml-2.6/Makefile.in       2011-07-13 07:25:36.615999491 +0300
-@@ -59,7 +59,7 @@
- # Install commands...
- #
--INSTALL_BIN   =       $(LIBTOOL) $(INSTALL) -m 755 -s
-+INSTALL_BIN   =       $(LIBTOOL) $(INSTALL) -m 755
- INSTALL_DATA  =       $(INSTALL) -m 644
- INSTALL_DIR   =       $(INSTALL) -d
- INSTALL_LIB   =       $(LIBTOOL) $(INSTALL) -m 755
-@@ -88,7 +88,7 @@
-                       mxml-node.o mxml-search.o mxml-set.o
- LIBOBJS               =       $(PUBLIBOBJS) mxml-private.o mxml-string.o
- OBJS          =       mxmldoc.o testmxml.o $(LIBOBJS)
--TARGETS               =       $(LIBMXML) mxmldoc testmxml mxml.xml doc/mxml.man
-+TARGETS               =       $(LIBMXML) libmxml.a
- #
-@@ -134,8 +134,6 @@
- #
- install:      $(TARGETS) install-$(LIBMXML) install-libmxml.a
--      $(INSTALL_DIR) $(BUILDROOT)$(bindir)
--      $(INSTALL_BIN) mxmldoc $(BUILDROOT)$(bindir) 
-       $(INSTALL_DIR) $(BUILDROOT)$(docdir)
-       for file in $(DOCFILES); do \
-               $(INSTALL_MAN) $$file $(BUILDROOT)$(docdir); \
-@@ -144,10 +142,6 @@
-       $(INSTALL_DATA) mxml.h $(BUILDROOT)$(includedir)
-       $(INSTALL_DIR) $(BUILDROOT)$(libdir)/pkgconfig
-       $(INSTALL_DATA) mxml.pc $(BUILDROOT)$(libdir)/pkgconfig
--      $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man1
--      $(INSTALL_MAN) doc/mxmldoc.man $(BUILDROOT)$(mandir)/man1/mxmldoc.1
--      $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man3
--      $(INSTALL_MAN) doc/mxml.man $(BUILDROOT)$(mandir)/man3/mxml.3
- install-libmxml.a:
-       $(INSTALL_DIR) $(BUILDROOT)$(libdir)
diff --git a/package/mxml/mxml-fix-cross-target-installation.patch b/package/mxml/mxml-fix-cross-target-installation.patch
new file mode 100644 (file)
index 0000000..3a9fa0c
--- /dev/null
@@ -0,0 +1,55 @@
+From: Baruch Siach <baruch@tkos.co.il>
+Subject: [PATCH] mxml: workaround for cross build
+
+The added patch is a workaround for cross build as follows:
+
+       * disable run of a test binary at build time
+       * disable generation of documentation using the mxmldoc binary
+       * remove now non-existent entries from the install target
+       * disable strip when running install
+
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+---
+diff -Nuar mxml-2.7-orig/Makefile.in mxml-2.7/Makefile.in
+--- mxml-2.7-orig/Makefile.in  2011-04-13 18:43:32.000000000 +0300
++++ mxml-2.7/Makefile.in       2012-05-16 07:21:42.677220980 +0300
+@@ -57,7 +57,7 @@
+ # Install commands...
+ #
+-INSTALL_BIN   =       $(LIBTOOL) $(INSTALL) -m 755 -s
++INSTALL_BIN   =       $(LIBTOOL) $(INSTALL) -m 755
+ INSTALL_DATA  =       $(INSTALL) -m 644
+ INSTALL_DIR   =       $(INSTALL) -d
+ INSTALL_LIB   =       $(LIBTOOL) $(INSTALL) -m 755
+@@ -88,7 +88,7 @@
+                       mxml-index.o mxml-node.o mxml-search.o mxml-set.o
+ LIBOBJS               =       $(PUBLIBOBJS) mxml-private.o mxml-string.o
+ OBJS          =       mxmldoc.o testmxml.o $(LIBOBJS)
+-TARGETS               =       $(LIBMXML) mxmldoc testmxml mxml.xml doc/mxml.man
++TARGETS               =       $(LIBMXML) libmxml.a
+ #
+@@ -140,9 +140,6 @@
+ #
+ install:      $(TARGETS) install-$(LIBMXML) install-libmxml.a
+-      echo Installing mxmldoc in $(BUILDROOT)$(bindir)...
+-      $(INSTALL_DIR) $(BUILDROOT)$(bindir)
+-      $(INSTALL_BIN) mxmldoc $(BUILDROOT)$(bindir)
+       echo Installing documentation in $(BUILDROOT)$(docdir)...
+       $(INSTALL_DIR) $(BUILDROOT)$(docdir)
+       for file in $(DOCFILES); do \
+@@ -154,11 +151,6 @@
+       echo Installing pkgconfig files in $(BUILDROOT)$(libdir)/pkgconfig...
+       $(INSTALL_DIR) $(BUILDROOT)$(libdir)/pkgconfig
+       $(INSTALL_DATA) mxml.pc $(BUILDROOT)$(libdir)/pkgconfig
+-      echo Installing man pages in $(BUILDROOT)$(mandir)...
+-      $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man1
+-      $(INSTALL_MAN) doc/mxmldoc.man $(BUILDROOT)$(mandir)/man1/mxmldoc.1
+-      $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man3
+-      $(INSTALL_MAN) doc/mxml.man $(BUILDROOT)$(mandir)/man3/mxml.3
+ install-libmxml.a:
+       echo Installing libmxml.a to $(BUILDROOT)$(libdir)...
index c05c3a7060f1b8d7bcb30c7e855531da61bcf43c..ca54a54f7e4548f68ecfe804b4b6a849d9fe2805 100644 (file)
@@ -3,8 +3,8 @@
 # mxml
 #
 #############################################################
-MXML_VERSION = 2.6
-MXML_SITE = http://ftp.easysw.com/pub/mxml/2.6
+MXML_VERSION = 2.7
+MXML_SITE = http://ftp.easysw.com/pub/mxml/$(MXML_VERSION)
 MXML_INSTALL_STAGING = YES
 
 MXML_INSTALL_STAGING_OPT = DSTROOT=$(STAGING_DIR) install