blackbox: needs iconv if !locale
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 2 Jul 2010 12:04:34 +0000 (14:04 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 2 Jul 2010 12:04:34 +0000 (14:04 +0200)
Closes #2101

At the same time fix dependencies so it can be built without a local
X server, and a comment is shown if C++ support isn't enabled.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/blackbox/Config.in
package/blackbox/blackbox.mk

diff --git a/CHANGES b/CHANGES
index a889324634fc93fd7820902a4710bac36ff39ab9..7e95a3bf4d240e36fc262527ac584d661a8f5a61 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        New packages: cgilua, copas, coxpcall, ffmpeg, luafilesystem,
        luasocket, rings, wsapi, xavante, xterm
 
-       Updated/fixed packages: berkeleydb, bash, busybox, cdrkit, dash,
-       dialog, diffutils, distcc, dmalloc, dnsmasq, dropbear, fbv,
-       file, gawk, gstreamer, gzip, intltool, ipsec-tools, iptables,
-       libart, libfuse, libgpg-error, libidn, liblockfile, links,
-       lmbench, lrzsz, make, module-init-tools, nbd, ncurses, netperf,
-       ntfsprogs, openssl, php, qt, quagga, sqlite, sdl, sdl_mixer,
-       sdl_ttf, squashfs, tn5250, tremor, usbutils, xkeyboard-config,
-       xserver_xorg-server
+       Updated/fixed packages: berkeleydb, bash, blackbox, busybox,
+       cdrkit, dash, dialog, diffutils, distcc, dmalloc, dnsmasq,
+       dropbear, fbv, file, gawk, gstreamer, gzip, intltool,
+       ipsec-tools, iptables, libart, libfuse, libgpg-error, libidn,
+       liblockfile, links, lmbench, lrzsz, make, module-init-tools,
+       nbd, ncurses, netperf, ntfsprogs, openssl, php, qt, quagga,
+       sqlite, sdl, sdl_mixer, sdl_ttf, squashfs, tn5250, tremor,
+       usbutils, xkeyboard-config, xserver_xorg-server
 
        Removed packages: modutils, portage, rxvt
 
@@ -51,6 +51,7 @@
        #2035: ipsec-tools-0.7.2 fails to build with gcc-4.4.x
        #2038: Bump ncurses to 5.7
        #2095: make gconfig: undefined reference to symbol 'dlsym@@GLIBC_2.2.5'
+       #2101: blackbox depends on locale support
        #2119: Tries to build kernel, although disabled in config
        #2155: Compression lzo don't set for ubifs
 
index bf237c53a434c7710de5f691ce364de0efce0f64..70f7eb4b57042a3f5c54b700c687b29f401d5a3f 100644 (file)
@@ -2,8 +2,13 @@ config BR2_PACKAGE_BLACKBOX
        bool "blackbox"
        depends on BR2_PACKAGE_XORG7
        depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+       select BR2_PACKAGE_XLIB_LIBX11
        help
          Blackbox is a fast, lightweight window manager for the X
          Window System.
 
          http://blackboxwm.sourceforge.net/
+
+comment "blackbox requires a toolchain with C++ support enabled"
+       depends on BR2_PACKAGE_XORG7 && !BR2_INSTALL_LIBSTDCPP
index 41deb5860b31cee7d615789b38ab2008fff9c53e..e3c8c341b36f14ca62caddaefcf149593de5d5a2 100644 (file)
@@ -14,6 +14,10 @@ BLACKBOX_INSTALL_TARGET:=YES
 BLACKBOX_CONF_OPT:=--x-includes=$(STAGING_DIR)/usr/include/X11 \
                --x-libraries=$(STAGING_DIR)/usr/lib
 
-BLACKBOX_DEPENDENCIES:=xserver_xorg-server
+BLACKBOX_DEPENDENCIES = xlib_libX11
+
+ifneq ($(BR2_ENABLE_LOCALE),y)
+BLACKBOX_DEPENDENCIES += libiconv
+endif
 
 $(eval $(call AUTOTARGETS,package,blackbox))