rng-tools: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 2 Nov 2010 19:35:35 +0000 (16:35 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Nov 2010 23:02:04 +0000 (00:02 +0100)
[Peter: fix dependencies]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/rng-tools/Config.in [new file with mode: 0644]
package/rng-tools/rng-tools.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 019ce09aa9a2d90ae1ce0e9db98bd5718d86fd34..f9ab2b88ebf172ea9f3f449bbcc1f7fffffc350a 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -22,7 +22,7 @@
        Alpha, Cris, IA64 and Sparc64 architecture support removed.
 
        New packages: argp-standalone, gdk-pixbuf, gpsd, gst-ffmpeg,
-       libmpeg2, librsvg, rrdtool, xz
+       libmpeg2, librsvg, rng-tools, rrdtool, xz
 
        Updated/fixed packages: acpid, alsa-lib, argus, at, autoconf,
        automake, avahi, axel, beecrypt, berkeleydb, bind, bmon, boa,
index a86b6b347ff33fa95e1ccacaa3b476eb289e92c2..4e61ea98aa6267f2cb06bc20d944164849d63288 100644 (file)
@@ -182,6 +182,7 @@ source "package/mtd/Config.in"
 source "package/ntfs-3g/Config.in"
 source "package/ntfsprogs/Config.in"
 source "package/pciutils/Config.in"
+source "package/rng-tools/Config.in"
 source "package/setserial/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 # busybox has fdisk
diff --git a/package/rng-tools/Config.in b/package/rng-tools/Config.in
new file mode 100644 (file)
index 0000000..e6dcf9d
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RNG_TOOLS
+       bool "rng-tools"
+       select BR2_PACKAGE_ARGP_STANDALONE
+       help
+         Daemon to use hardware random number generators.
+
+         http://sourceforge.net/projects/gkernel/
diff --git a/package/rng-tools/rng-tools.mk b/package/rng-tools/rng-tools.mk
new file mode 100644 (file)
index 0000000..755f4f8
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# rng-tools
+#
+#############################################################
+
+RNG_TOOLS_VERSION = 3
+RNG_TOOLS_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/gkernel
+RNG_TOOLS_CONF_ENV = LIBS="-largp"
+RNG_TOOLS_USE_CONFIG_CACHE = NO
+RNG_TOOLS_DEPENDENCIES = argp-standalone
+
+$(eval $(call AUTOTARGETS,package,rng-tools))