monkey: add option for SSL/TLS plugin compilation
authorDavid Pierret <david.pierret@gmail.com>
Mon, 17 Sep 2018 13:05:49 +0000 (15:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 18 Sep 2018 19:41:15 +0000 (21:41 +0200)
This commit add an option to enable SSL/TLS plugin compilation who is
not build by default.

Signed-off-by: David Pierret <david.pierret@gmail.com>
[Thomas: add missing dependency on mbedtls.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/monkey/Config.in
package/monkey/monkey.mk

index 9054aa05c269f2ab43db96827d8f4b8c818f5aa5..fdfa1481e4ce971c7313c03de5111da034cc33a2 100644 (file)
@@ -17,6 +17,12 @@ config BR2_PACKAGE_MONKEY_SHARED
          Build Monkey as a shared library in addition to stand-alone
          server
 
+config BR2_PACKAGE_MONKEY_SSL
+       bool "enable SSL/TLS"
+       select BR2_PACKAGE_MBEDTLS
+       help
+         Enable build of the SSL/TLS plugin.
+
 endif
 
 comment "monkey needs an toolchain w/ threads, dynamic library"
index 58bc26e6857e1adce2858b980d4add3b91677b3d..b75765553bb00d939fcc2625360a77785b4655e9 100644 (file)
@@ -48,6 +48,11 @@ ifeq ($(BR2_ENABLE_DEBUG),y)
 MONKEY_CONF_OPTS += --debug
 endif
 
+ifeq ($(BR2_PACKAGE_MONKEY_SSL),y)
+MONKEY_CONF_OPTS += --enable-plugins=tls --mbedtls-shared
+MONKEY_DEPENDENCIES += mbedtls
+endif
+
 define MONKEY_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure $(MONKEY_CONF_OPTS))
 endef