package/qt5/qt5lottie: new package
authorPeter Seiderer <ps.report@gmx.net>
Mon, 12 Oct 2020 21:16:17 +0000 (23:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 14 Oct 2020 21:33:20 +0000 (23:33 +0200)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/Config.in
package/qt5/qt5lottie/Config.in [new file with mode: 0644]
package/qt5/qt5lottie/qt5lottie.hash [new file with mode: 0644]
package/qt5/qt5lottie/qt5lottie.mk [new file with mode: 0644]

index c31f8267f329bd7b4565f806582b24c9aadab706..fc0e68e8b744a4db127094cb653d52832574fb99 100644 (file)
@@ -46,6 +46,7 @@ source "package/qt5/qt5enginio/Config.in"
 source "package/qt5/qt5graphicaleffects/Config.in"
 source "package/qt5/qt5imageformats/Config.in"
 source "package/qt5/qt5location/Config.in"
+source "package/qt5/qt5lottie/Config.in"
 source "package/qt5/qt5multimedia/Config.in"
 source "package/qt5/qt5quickcontrols/Config.in"
 source "package/qt5/qt5quickcontrols2/Config.in"
diff --git a/package/qt5/qt5lottie/Config.in b/package/qt5/qt5lottie/Config.in
new file mode 100644 (file)
index 0000000..de5f16d
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_QT5LOTTIE
+       bool "qt5lottie"
+       depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
+       select BR2_PACKAGE_QT5DECLARATIVE
+       select BR2_PACKAGE_QT5DECLARATIVE_QUICK
+       help
+         Qt is a cross-platform application and UI framework for
+         developers using C++.
+
+         This package corresponds to the qt5lottie module.
+
+         https://doc.qt.io/qt-5/qtlottieanimation-index.html
diff --git a/package/qt5/qt5lottie/qt5lottie.hash b/package/qt5/qt5lottie/qt5lottie.hash
new file mode 100644 (file)
index 0000000..3af1c6d
--- /dev/null
@@ -0,0 +1,6 @@
+# Hash from: http://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtlottie-everywhere-src-5.15.1.tar.xz.sha256
+sha256  845987860c7990035a7cd9a0e7581d210f786e551882df8b5be69f08987f2ba0  qtlottie-everywhere-src-5.15.1.tar.xz
+
+# Hashes for license files:
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE.GPL3
+sha256  0dbe024961f6ab5c52689cbd036c977975d0d0f6a67ff97762d96cb819dd5652  LICENSE.GPL3-EXCEPT
diff --git a/package/qt5/qt5lottie/qt5lottie.mk b/package/qt5/qt5lottie/qt5lottie.mk
new file mode 100644 (file)
index 0000000..1423a62
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# qt5lottie
+#
+################################################################################
+
+QT5LOTTIE_VERSION = $(QT5_VERSION)
+QT5LOTTIE_SITE = $(QT5_SITE)
+QT5LOTTIE_SOURCE = qtlottie-$(QT5_SOURCE_TARBALL_PREFIX)-$(QT5LOTTIE_VERSION).tar.xz
+QT5LOTTIE_DEPENDENCIES = qt5declarative
+QT5LOTTIE_INSTALL_STAGING = YES
+
+QT5LOTTIE_LICENSE = GPL-3.0
+QT5LOTTIE_LICENSE_FILES = LICENSE.GPL3 LICENSE.GPL3-EXCEPT
+
+$(eval $(qmake-package))