ipset: ensure target kernel headers are used
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 22 Jul 2011 11:51:45 +0000 (13:51 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 22 Jul 2011 11:51:45 +0000 (13:51 +0200)
ipsets configure script checks the kernel headers to ensure the kernel
is new enough / has patch applied, and errors out if this is not so.

Ensure that the target kernel headers are searched, rather than
what is available on the build host.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ipset/ipset.mk

index 9d901fc53edd74a13e8e3990a63610e58c9ac105..700d2bc229455ebb7cabd19d47ca8e8a31d440bb 100644 (file)
@@ -9,5 +9,6 @@ IPSET_SOURCE = ipset-$(IPSET_VERSION).tar.bz2
 IPSET_SITE = http://ipset.netfilter.org
 IPSET_AUTORECONF = YES
 IPSET_DEPENDENCIES = libmnl host-pkg-config
+IPSET_CONF_OPT = --with-ksource=$(LINUX_HEADERS_DIR)
 
 $(eval $(call AUTOTARGETS,package,ipset))