package/efl: avoid optimization flags added by meson
authorRomain Naour <romain.naour@gmail.com>
Sat, 8 Aug 2020 09:42:30 +0000 (11:42 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 8 Aug 2020 12:23:24 +0000 (14:23 +0200)
Efl's meson build system add some optimization flags related to cpu
architecture [1]. In the context of Buildroot, such optimization flags
are already provided by the toolchain wrapper.

For ppc, efl's meson expect the altivec support is available but this is
not the case for ppc e500 cpus.

Disable native-arch-optimization option to avoid such issue.

[1] https://git.enlightenment.org/core/efl.git/tree/meson.build?h=v1.24.3#n165

Fixes:
http://autobuild.buildroot.net/results/dd2586be32c25d93eebfaa743c1f7d36915bb0d7

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/efl/efl.mk

index 6dc38b1626bed3904f325a853247c76d5c44aacc..b8c4a506ad3b89ffc4cab2d6743177224cccac29 100644 (file)
@@ -29,6 +29,7 @@ EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
 # elua=true: build elua for the target.
 # sdl=false: disable sdl2 support.
 # embedded-lz4=false: use liblz4 from lz4 package.
+# native-arch-optimization=false: avoid optimization flags added by meson.
 # network-backend=none: disable connman networkmanager.
 EFL_CONF_OPTS = \
        -Davahi=false \
@@ -39,6 +40,7 @@ EFL_CONF_OPTS = \
        -Delua=true \
        -Dembedded-lz4=false \
        -Dlua-interpreter=luajit \
+       -Dnative-arch-optimization=false \
        -Dnetwork-backend=none \
        -Dpixman=false \
        -Dsdl=false \