package/fftw: break fftw-long-double into a dedicated package
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Mon, 21 Jan 2019 13:50:57 +0000 (14:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 09:14:46 +0000 (10:14 +0100)
fftw's library name depends on the precision option. Consequently,
it's possible to install multiple flavor on the same target.

This patch breaks fftw long double precision into a new package and:

- makes BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE select
  BR2_PACKAGE_FFTW_LONG_DOUBLE to keep compatibility with packages
  that use BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE. This option will be
  removed in a follow-up commit;

- makes fftw depend on fftw-long-double when this package is enabled.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
[Yann/Thomas:
 - Force --disable-long-double in FFTW_CONF_OPTS, just for the sake of
   clarity (fftw is no longer going to build the long double variant)
 - Use FFTW_LONG_DOUBLE_DL_SUBDIR to avoid downloading fftw multiple times
 - Minor reformatting tweaks in fftw-long-double.mk
 - Do not deprecate BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE and instead
   make it select BR2_PACKAGE_FFTW_LONG_DOUBLE, so that packages using
   BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE continue to work.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/fftw/Config.in
package/fftw/fftw-long-double/Config.in [new file with mode: 0644]
package/fftw/fftw-long-double/fftw-long-double.hash [new symlink]
package/fftw/fftw-long-double/fftw-long-double.mk [new file with mode: 0644]
package/fftw/fftw.mk

index f61784de507851bc07e547156a18bc9bfbb8c80a..4f37b43a6093c99459d760b37da365064beef2da 100644 (file)
@@ -40,6 +40,7 @@ config BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE
        # long-double precision require long-double trigonometric routines
        depends on !(BR2_TOOLCHAIN_BUILDROOT_UCLIBC && \
                (BR2_arm || BR2_mips || BR2_mipsel))
+       select BR2_PACKAGE_FFTW_LONG_DOUBLE
        help
          Compile fftw in long double precision, i.e. use 'long double'
          for floating point type.
@@ -55,6 +56,7 @@ config BR2_PACKAGE_FFTW_PRECISION_QUAD
 endchoice
 
 source "package/fftw/fftw-single/Config.in"
+source "package/fftw/fftw-long-double/Config.in"
 
 config BR2_PACKAGE_FFTW_FAST
        bool "optimise for speed over accuracy"
diff --git a/package/fftw/fftw-long-double/Config.in b/package/fftw/fftw-long-double/Config.in
new file mode 100644 (file)
index 0000000..3ee1762
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FFTW_LONG_DOUBLE
+       bool "fftw-long-double"
+       # long-double precision require long-double trigonometric routines
+       depends on !(BR2_TOOLCHAIN_USES_UCLIBC && \
+               (BR2_arm || BR2_mips || BR2_mipsel))
+       help
+         Compile fftw in long double precision, i.e. use 'long double'
+         for floating point type.
diff --git a/package/fftw/fftw-long-double/fftw-long-double.hash b/package/fftw/fftw-long-double/fftw-long-double.hash
new file mode 120000 (symlink)
index 0000000..3ee7ecb
--- /dev/null
@@ -0,0 +1 @@
+../fftw.hash
\ No newline at end of file
diff --git a/package/fftw/fftw-long-double/fftw-long-double.mk b/package/fftw/fftw-long-double/fftw-long-double.mk
new file mode 100644 (file)
index 0000000..1730504
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# fftw-long-double
+#
+################################################################################
+
+FFTW_LONG_DOUBLE_VERSION = $(FFTW_VERSION)
+FFTW_LONG_DOUBLE_SOURCE = fftw-$(FFTW_VERSION).tar.gz
+FFTW_LONG_DOUBLE_SITE = $(FFTW_SITE)
+FFTW_LONG_DOUBLE_DL_SUBDIR = fftw
+FFTW_LONG_DOUBLE_INSTALL_STAGING = $(FFTW_INSTALL_STAGING)
+FFTW_LONG_DOUBLE_LICENSE = $(FFTW_LICENSE)
+FFTW_LONG_DOUBLE_LICENSE_FILES = $(FFTW_LICENSE_FILES)
+
+FFTW_LONG_DOUBLE_CONF_ENV = $(FFTW_COMMON_CONF_ENV)
+
+FFTW_LONG_DOUBLE_CONF_OPTS = \
+       $(FFTW_COMMON_CONF_OPTS) \
+       CFLAGS="$(FFTW_COMMON_CFLAGS)" \
+       --enable-long-double
+
+$(eval $(autotools-package))
index b7389280322ab6ef31e8e5ac193067c90f3e71a9..26137b9f7c96c685917950027bff131da2448cf6 100644 (file)
@@ -10,6 +10,10 @@ FFTW_INSTALL_STAGING = YES
 FFTW_LICENSE = GPL-2.0+
 FFTW_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_FFTW_LONG_DOUBLE),y)
+FFTW_DEPENDENCIES += fftw-long-double
+endif
+
 ifeq ($(BR2_PACKAGE_FFTW_SINGLE),y)
 FFTW_DEPENDENCIES += fftw-single
 endif
@@ -44,7 +48,7 @@ FFTW_CONF_ENV = $(FFTW_COMMON_CONF_ENV)
 FFTW_CONF_OPTS += \
        $(FFTW_COMMON_CONF_OPTS) \
        --disable-single \
-       $(if $(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),--enable,--disable)-long-double \
+       --disable-long-double \
        $(if $(BR2_PACKAGE_FFTW_PRECISION_QUAD),--enable,--disable)-quad-precision \
        CFLAGS="$(FFTW_COMMON_CFLAGS)"