toolchain-external: bump Linaro ARM toolchain to 2016.11
authorRomain Naour <romain.naour@gmail.com>
Tue, 29 Nov 2016 21:42:59 +0000 (22:42 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Nov 2016 20:57:03 +0000 (21:57 +0100)
Tested with qemu-2.4.1-11.fc23 and the qemu_arm_vexpress_defconfig

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/toolchain-external-linaro-arm/Config.in
toolchain/toolchain-external/toolchain-external-linaro-arm/toolchain-external-linaro-arm.hash
toolchain/toolchain-external/toolchain-external-linaro-arm/toolchain-external-linaro-arm.mk

index bf8649acfb994669b02bbdabf52955b82de8aea5..cef42e744179f8e7cea2d6e9290b59191946bdcf 100644 (file)
@@ -4,7 +4,7 @@ comment "Linaro toolchains available for Cortex-A + EABIhf"
        depends on !BR2_STATIC_LIBS
 
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
-       bool "Linaro ARM 2016.05"
+       bool "Linaro ARM 2016.11"
        depends on BR2_arm
        depends on BR2_ARM_CPU_ARMV7A
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -14,13 +14,13 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
        select BR2_TOOLCHAIN_HAS_SSP
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
        select BR2_INSTALL_LIBSTDCPP
-       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_0
-       select BR2_TOOLCHAIN_GCC_AT_LEAST_5
+       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_6
+       select BR2_TOOLCHAIN_GCC_AT_LEAST_6
        select BR2_TOOLCHAIN_HAS_FORTRAN
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2016.05 (based on gcc 5.3.1), Linaro GDB 2016.05 (based on
-         GDB 7.11.1), glibc 2.21, Binutils 2016.05 (based on 2.25). It
+         GCC 2016.11 (based on gcc 6.2.1), Linaro GDB 2016.11 (based on
+         GDB 7.12), glibc 2.23, Binutils 2016.11 (based on 2.27). It
          generates code that runs on all Cortex-A profile devices,
          but tuned for the Cortex-A9. The code generated is Thumb 2,
          with the hard floating point calling convention, and uses
index 810642621480e9f6f6bcfe9de43b7a3c1c50215b..d4452c37866cdcfae2f7056d6e0ba15e245e6fe6 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 f1421c580ce977226f4fefc9c409b3b423260cc65a6e9dc6da88bb3478a521a0  gcc-linaro-5.3.1-2016.05-i686_arm-linux-gnueabihf.tar.xz
-sha256 987941c9fffdf56ffcbe90e8984673c16648c477b537fcf43add22fa62f161cd  gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabihf.tar.xz
+sha256 a2a4968bfb8537c1b3280b4f475d90d53a1a0f05f7afc7b43efed266cc4de446  gcc-linaro-6.2.1-2016.11-i686_arm-linux-gnueabihf.tar.xz
+sha256 5eb7ab2f8a0b4b960900321505cd6923a072cb3e2412102f5f72a6e74c2f0a55  gcc-linaro-6.2.1-2016.11-x86_64_arm-linux-gnueabihf.tar.xz
index 64918cac02d432d2d7fdfedabbe19727290aa3c1..e098f4775700d393947dde3b4fd836b820354063 100644 (file)
@@ -4,13 +4,13 @@
 #
 ################################################################################
 
-TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION = 2016.05
-TOOLCHAIN_EXTERNAL_LINARO_ARM_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)/arm-linux-gnueabihf
+TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION = 2016.11
+TOOLCHAIN_EXTERNAL_LINARO_ARM_SITE = https://releases.linaro.org/components/toolchain/binaries/6.2-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)/arm-linux-gnueabihf
 
 ifeq ($(HOSTARCH),x86)
-TOOLCHAIN_EXTERNAL_LINARO_ARM_SOURCE = gcc-linaro-5.3.1-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)-i686_arm-linux-gnueabihf.tar.xz
+TOOLCHAIN_EXTERNAL_LINARO_ARM_SOURCE = gcc-linaro-6.2.1-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)-i686_arm-linux-gnueabihf.tar.xz
 else
-TOOLCHAIN_EXTERNAL_LINARO_ARM_SOURCE = gcc-linaro-5.3.1-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)-x86_64_arm-linux-gnueabihf.tar.xz
+TOOLCHAIN_EXTERNAL_LINARO_ARM_SOURCE = gcc-linaro-6.2.1-$(TOOLCHAIN_EXTERNAL_LINARO_ARM_VERSION)-x86_64_arm-linux-gnueabihf.tar.xz
 endif
 
 $(eval $(toolchain-external-package))