sdl_sound: refactor *_CONF_OPT assignment with cpu-feature options
authorSamuel Martin <s.martin49@gmail.com>
Mon, 16 Jul 2012 21:37:29 +0000 (23:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Jul 2012 07:54:59 +0000 (09:54 +0200)
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sdl_sound/sdl_sound.mk

index a5d9a26d56dc77b2e88ebccd573b8e4e848f3d59..620b3b4692ef4251ac06a9fe82186cef0d11d416 100644 (file)
@@ -32,8 +32,7 @@ SDL_SOUND_CONF_OPT = \
        --disable-sdltest \
        --enable-static
 
-# enable mmx for newer x86's
-ifeq ($(BR2_i386)$(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
+ifeq ($(BR2_X86_CPU_HAS_MMX),y)
 SDL_SOUND_CONF_OPT += --enable-mmx
 else
 SDL_SOUND_CONF_OPT += --disable-mmx