package/pulseaudio: needs xdg SELinux module
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 5 Sep 2021 19:51:28 +0000 (21:51 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 12 Sep 2021 12:31:27 +0000 (14:31 +0200)
xdg is needed (and can't be make optional as it is unconditionally used
in pulseaudio.fc) to fix the following build failure raised since commit
bf44a11cf67fde4ba96928a2a4196103b7ec4ef3:

 Compiling targeted policy.33
 env LD_LIBRARY_PATH="/tmp/instance-0/output-1/host/lib:/tmp/instance-0/output-1/host/usr/lib" /tmp/instance-0/output-1/host/usr/bin/checkpolicy -c 33 -U deny -S -O -E policy.conf -o policy.33
 policy/modules/apps/pulseaudio.te:44:ERROR 'attribute xdg_config_type is not declared' at token ';' on line 317285:
 #line 44
typeattribute pulseaudio_xdg_config_t xdg_config_type;
 checkpolicy:  error(s) encountered while parsing configuration
 make[1]: *** [Rules.monolithic:79: policy.33] Error 1

Fixes:
 - http://autobuild.buildroot.org/results/818219c0f722080d9f6ef778fdc50e34dd4187ab

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/pulseaudio/pulseaudio.mk

index 372cd98da84b422d9a3da2d2d62836489b3d1b62..a238315778ef228ccef23f08914c280671c22059 100644 (file)
@@ -11,7 +11,7 @@ PULSEAUDIO_INSTALL_STAGING = YES
 PULSEAUDIO_LICENSE = LGPL-2.1+ (specific license for modules, see LICENSE file)
 PULSEAUDIO_LICENSE_FILES = LICENSE GPL LGPL
 PULSEAUDIO_CPE_ID_VENDOR = pulseaudio
-PULSEAUDIO_SELINUX_MODULES = pulseaudio
+PULSEAUDIO_SELINUX_MODULES = pulseaudio xdg
 PULSEAUDIO_CONF_OPTS = \
        --disable-default-build-tests \
        --disable-legacy-database-entry-format \