package/pkg-generic.mk: use $(PKG)_NAME in step_pkg_size_after
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 30 Apr 2020 09:52:38 +0000 (11:52 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 23 Jul 2020 20:31:21 +0000 (22:31 +0200)
Since we're already using $(PKG)_DIR in step_pkg_size_after, we can
also just use $(PKG)_NAME. This allows to make $(1) useless, which
means it can be dropped in a follow-up commit.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-generic.mk

index f9385177ac6d98658be301a82e02e38185c4be21..4ea1084f91ad918a2b5324579a4e159388f918cb 100644 (file)
@@ -76,7 +76,7 @@ define step_pkg_size_after
        LC_ALL=C comm -13 \
                $($(PKG)_DIR)/.files-list$(3).before \
                $($(PKG)_DIR)/.files-list$(3).after \
-               | sed -r -e 's/^[^,]+/$(1)/' \
+               | sed -r -e 's/^[^,]+/$($(PKG)_NAME)/' \
                > $($(PKG)_DIR)/.files-list$(3).txt
        rm -f $($(PKG)_DIR)/.files-list$(3).before
        rm -f $($(PKG)_DIR)/.files-list$(3).after