qt5base: use ccache if enabled
authorFatih Aşıcı <fatih.asici@gmail.com>
Fri, 29 Nov 2013 08:47:49 +0000 (10:47 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Nov 2013 09:09:45 +0000 (10:09 +0100)
For now, it doesn't use ccache when compiling host tools (e.g. qmake).
It seems the fix is not trivial.

Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5base/qt5base.mk

index febdc9b71c0577a2b99bbbb21d3f11ba68046387..d95b186eb6614b5eb0e1fc47b3d28af91b4a1696 100644 (file)
@@ -167,7 +167,7 @@ define QT5BASE_CONFIGURE_CMDS
                -no-rpath \
                -nomake examples -nomake tests \
                -device buildroot \
-               -device-option CROSS_COMPILE="$(TARGET_CROSS)" \
+               -device-option CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
                -device-option BUILDROOT_COMPILER_CFLAGS="$(TARGET_CFLAGS)" \
                -device-option BUILDROOT_COMPILER_CXXFLAGS="$(TARGET_CXXFLAGS)" \
                -device-option EGLFS_PLATFORM_HOOKS_SOURCES="$(QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES)" \