package/mc: Fix xlib_libX11 dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 2 Apr 2015 19:28:57 +0000 (21:28 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 2 Apr 2015 21:17:08 +0000 (23:17 +0200)
On PeterĀ“s autobuilder building mc fails:
http://autobuild.buildroot.net/?reason=mc-4.8.14

The reason can be found in
http://autobuild.buildroot.net/results/e25/e25587c17c2e8ddae83f9ed02541931f510bfcd6//build-end.log

checking for X... libraries /usr/lib, headers /usr/include

where configure picks up xorg libraries although no x11 stuff is enabled in the
defconfig used for this build.

This leads to subsequent errors visible in
http://autobuild.buildroot.net/results/e25/e25587c17c2e8ddae83f9ed02541931f510bfcd6//mc-4.8.14/config.log

mips64el-ctng_n64-linux-gnu-gcc: ERROR: unsafe header/library path used in cross-compilation: '/usr/lib'

causing most configure checks to fail afterwards. To fix the problem the mc
package should honour an optional dependency to the xlib_libX11 package.

Fixes
http://autobuild.buildroot.net/results/e25/e25587c17c2e8ddae83f9ed02541931f510bfcd6/
http://autobuild.buildroot.net/results/b7a/b7a2b69c53e91e0173b7f0c241d7e06b4382c52a/
http://autobuild.buildroot.net/results/805/805675236190f7f5f42d498f4a9f9bf0e1bab648/
and others

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mc/mc.mk

index 9e65e493761a1c6e51c3531aa8905e8f8ca05e01..f96d396f0ddd7d24060e7f78eaf697074e591ad4 100644 (file)
@@ -22,4 +22,11 @@ MC_DEPENDENCIES += ncurses
 MC_CONF_OPTS += --with-screen=ncurses
 endif
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
+MC_CONF_OPTS += --with-x
+MC_DEPENDENCIES += xlib_libX11
+else
+MC_CONF_OPTS += --without-x
+endif
+
 $(eval $(autotools-package))