package/aespipe: fix host compile
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 17 Dec 2016 07:16:59 +0000 (08:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 17 Dec 2016 08:19:24 +0000 (09:19 +0100)
Building host-aespipe fails on

$ cat /etc/debian_version
stretch/sid

at linking stage:

/usr/bin/gcc -L/home/buildroot/br6/output/host/lib -L/home/buildroot/br6/output/host/usr/lib -Wl,-rpath,/home/buildroot/br6/output/host/usr/lib -o aespipe aespipe.o aes-amd64.o md5-amd64.o md5-2x-amd64.o aes-intel64.o sha512.o rmd160.o
/usr/bin/ld: aes-amd64.o: relocation R_X86_64_32S against `.rodata' can not be used when making a shared object; recompile with -fPIC

Fix is also used in Debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837393

[Peter: add comment explaining why]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/aespipe/aespipe.mk

index 6a38556ef1e709730b85b87cd2cc5dd4f67b5b92..8c7cd21850a4c7a6f2396a05cb8dd9a998591cc7 100644 (file)
@@ -9,5 +9,12 @@ AESPIPE_SOURCE = aespipe-v$(AESPIPE_VERSION).tar.bz2
 AESPIPE_SITE = http://loop-aes.sourceforge.net/aespipe
 AESPIPE_LICENSE = GPL
 
+# Debian enables -fPIE by default, breaking the build:
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837393
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835148
+HOST_AESPIPE_CONF_ENV = \
+       CFLAGS="$(HOST_CFLAGS) -no-pie" \
+       LDFLAGS="$(HOST_LDFLAGS) -no-pie"
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))