ltris: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:57:49 +0000 (22:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ltris/Config.in
package/ltris/ltris.mk

index bf73489da41024962058616c085ee84638d1bcd3..7d9dc04ad10992c4c0e133f97801340e8e9c6bc9 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_LTRIS
        bool "LTris"
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_SDL
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          LTris is a tetris clone, using SDL. It optionally requires
          SDL_mixer for audio support. A display with minimum 640x480
index 8f12ab153d6f157469a151c23e62884bb14ed4f0..fb0d4c34d2f4f5278a470cf7e31a3c034650b22f 100644 (file)
@@ -9,7 +9,8 @@ LTRIS_VERSION = 1.0.19
 LTRIS_LICENSE = GPL-2.0+
 LTRIS_LICENSE_FILES = COPYING
 
-LTRIS_DEPENDENCIES = sdl
+LTRIS_DEPENDENCIES = sdl $(TARGET_NLS_DEPENDENCIES)
+LTRIS_LIBS = $(TARGET_NLS_LIBS)
 
 LTRIS_CONF_ENV = \
        SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config" \
@@ -25,9 +26,4 @@ else
 LTRIS_CONF_OPTS += --disable-sound
 endif
 
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-LTRIS_DEPENDENCIES += gettext
-LTRIS_LIBS += -lintl
-endif
-
 $(eval $(autotools-package))