package/libgit2: disable NTLM support unconditionally.
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Mon, 24 May 2021 17:33:10 +0000 (19:33 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 May 2021 17:44:00 +0000 (19:44 +0200)
NTLM is an old authentication protocol depending on DES and MD4 and
its creator, Microsoft, discourage its use since 2010, because it is
weak and vulnerable to many attacks.

libgit2 has support for NTLM and it is enabled by default if openssl
is used, however, since commit a83d41867c8d ("package/libopenssl: add
option to enable some features"), support for DES and MD4 can be
disabled in openssl.

Since openssl is an optional dependency to libgit2 and getting rid of
NTLM is a goal in itself for many windows administrators, disable NTLM
by default.

Fixes: http://autobuild.buildroot.net/results/efb4ce2174cb6944558e895ce852182ba2738a70
Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libgit2/libgit2.mk

index e5d17fa3ddbb71ccc36aedf95326d56cc9e574c7..668fa758f85578cb9973aa588d57b5de83a4fad0 100644 (file)
@@ -17,6 +17,7 @@ LIBGIT2_CONF_OPTS = \
        -DUSE_ICONV=ON \
        -DREGEX_BACKEND=regcomp \
        -DUSE_HTTP_PARSER=system \
+       -DUSE_NTLMCLIENT=OFF \
        -DTHREADSAFE=$(if $(BR2_TOOLCHAIN_HAS_THREADS),ON,OFF)
 
 LIBGIT2_DEPENDENCIES = zlib libhttpparser