package/systemd: add userdb support
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 8 Mar 2020 09:39:58 +0000 (03:39 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Mar 2020 14:16:09 +0000 (15:16 +0100)
systemd-userdbd is a system service that multiplexes user/group lookups
to all local services that provide JSON user/group record definitions
to the system. In addition it synthesizes JSON user/group records from
classic UNIX/glibc NSS user/group records in order to provide full
backwards compatibility.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 6f5f5c3346232ea174ace431d300ccef3087dc18..bd638477a04fd0c7fe2720e833a7d2e1b5b6a279 100644 (file)
@@ -403,6 +403,18 @@ config BR2_PACKAGE_SYSTEMD_TMPFILES
 
          http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html
 
+config BR2_PACKAGE_SYSTEMD_USERDB
+       bool "enable userdb daemon"
+       help
+         systemd-userdbd is a system service that multiplexes
+         user/group lookups to all local services that provide JSON
+         user/group record definitions to the system. In addition it
+         synthesizes JSON user/group records from classic UNIX/glibc
+         NSS user/group records in order to provide full backwards
+         compatibility.
+
+         https://www.freedesktop.org/software/systemd/man/systemd-userdbd.service.html
+
 config BR2_PACKAGE_SYSTEMD_VCONSOLE
        bool "enable vconsole tool"
        default y
index c7a253bbe4169cc6219801fa384f13dde3eccf96..22165de2c148024a80c5a8e61bc4449d6d947e22 100644 (file)
@@ -41,7 +41,6 @@ SYSTEMD_CONF_OPTS += \
        -Dumount-path=/usr/bin/umount \
        -Dnobody-group=nogroup \
        -Didn=true \
-       -Duserdb=false \
        -Dhomed=false \
        -Dnss-systemd=true
 
@@ -311,6 +310,12 @@ else
 SYSTEMD_CONF_OPTS += -Drepart=false
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_USERDB),y)
+SYSTEMD_CONF_OPTS += -Duserdb=true
+else
+SYSTEMD_CONF_OPTS += -Duserdb=false
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_COREDUMP),y)
 SYSTEMD_CONF_OPTS += -Dcoredump=true
 SYSTEMD_COREDUMP_USER = systemd-coredump -1 systemd-coredump -1 * /var/lib/systemd/coredump - - Core Dumper