Patch correctly kexec, make sure utils is built using HOSTCC
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 24 Jul 2007 14:06:13 +0000 (14:06 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 24 Jul 2007 14:06:13 +0000 (14:06 -0000)
package/kexec/kexec-patch.sh [new file with mode: 0755]
package/kexec/kexec-tools-003-build-util-using-host-gcc.patch [new file with mode: 0644]
package/kexec/kexec.mk

diff --git a/package/kexec/kexec-patch.sh b/package/kexec/kexec-patch.sh
new file mode 100755 (executable)
index 0000000..4889705
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/bash
+SRCDIR=$1
+PATCHDIR=$2
+PATCHLIST=${PATCHDIR}/$3
+
+do_patch()
+{
+       cd ${SRCDIR}
+       for f in `cat ${PATCHLIST}` ; do
+               echo ${PATCHDIR}/$f
+               cat ${PATCHDIR}/$f | patch -p2
+       done
+}
+
+do_patch
+
diff --git a/package/kexec/kexec-tools-003-build-util-using-host-gcc.patch b/package/kexec/kexec-tools-003-build-util-using-host-gcc.patch
new file mode 100644 (file)
index 0000000..d2090d4
--- /dev/null
@@ -0,0 +1,17 @@
+diff -urN kexec-tools-1.101-0rig/util/Makefile kexec-tools-1.101/util/Makefile
+--- kexec-tools-1.101-0rig/util/Makefile       2004-12-16 22:08:21.000000000 +0100
++++ kexec-tools-1.101/util/Makefile    2007-07-24 16:32:48.000000000 +0200
+@@ -1,4 +1,4 @@
+ BIN_TO_HEX:= $(OBJDIR)/bin/bin-to-hex
+ $(BIN_TO_HEX): util/bin-to-hex.c
+       mkdir -p $(@D)
+-      $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
++      $(HOSTCC) $(HOST_CFLAGS) $< -o $@
+diff -urN kexec-tools-1.101-0rig/util/Makefile~ kexec-tools-1.101/util/Makefile~
+--- kexec-tools-1.101-0rig/util/Makefile~      1970-01-01 01:00:00.000000000 +0100
++++ kexec-tools-1.101/util/Makefile~   2004-12-16 22:08:21.000000000 +0100
+@@ -0,0 +1,4 @@
++BIN_TO_HEX:= $(OBJDIR)/bin/bin-to-hex
++$(BIN_TO_HEX): util/bin-to-hex.c
++      mkdir -p $(@D)
++      $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
index 36f2d8cc5a895f8936c08fc7131ea73e649cb9bd..c6155194f60472cf0b8775c3b111abc8de554edc 100644 (file)
@@ -35,9 +35,10 @@ $(KEXEC_DIR)/.unpacked: $(DL_DIR)/$(KEXEC_SOURCE) $(DL_DIR)/$(KEXEC_PATCH)
        $(KEXEC_CAT) $(DL_DIR)/$(KEXEC_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
 ifneq ($(KEXEC_PATCH),)
        (cd $(KEXEC_DIR) && $(KEXEC_CAT) $(DL_DIR)/$(KEXEC_PATCH) | patch -p1)
-       toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
+       package/kexec/kexec-patch.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches 00list
+#      toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
 endif
-       toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.dpatch
+       toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.patch
        touch $@
 
 $(KEXEC_DIR)/.configured: $(KEXEC_DIR)/.unpacked