pixman: fix patch for FE_DIVBYZERO detection
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 23 Feb 2014 10:08:25 +0000 (11:08 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 23 Feb 2014 11:30:02 +0000 (12:30 +0100)
In commit a9baea4345625f6f00fc59395faec83e08346015 ('pixman: add patch
to fix Microblaze build failure'), a patch is added to the pixman
package to avoid using the FE_DIVBYZERO definition when it is not
available. However, it was using the have_fe_divbyzero variable to
define or not HAVE_FEDIVBYZERO, while the AC_CHECK_DECL autoconf macro
sets the ac_cv_have_decl_FE_DIVBYZERO variable.

The end result was that the FE_DIVBYZERO macro was considered as never
being available. This commit fixes that by using the appropriate
variable.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pixman/pixman-02-check-fe-divbyzero.patch

index 44dd6913ed9586a17500738d30c2e34f393f80bb..01c6c96de694798bce3d804404ed2dfdb665dda9 100644 (file)
@@ -16,7 +16,7 @@ Index: b/configure.ac
  fi
  
 +AC_CHECK_DECL([FE_DIVBYZERO], [], [], [[#include <fenv.h>]])
-+if test x$have_fe_divbyzero = xyes; then
++if test x$ac_cv_have_decl_FE_DIVBYZERO = xyes; then
 +   AC_DEFINE(HAVE_FEDIVBYZERO, 1, [Whether we have FE_DIVBYZERO])
 +fi
 +