barebox: support multi-image-build image selection
authorPieter Smith <pieter@boesman.nl>
Sun, 24 Apr 2016 09:18:43 +0000 (11:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Apr 2016 15:36:55 +0000 (17:36 +0200)
Support optional selection of the built image filename in a
multi-image barebox build. This makes it possible to specify which
image to pick in a multi-image barebox config such as the
am335x_defconfig.

Signed-off-by: Pieter Smith <pieter@boesman.nl>
[Thomas:
 - remove default "", since this is the default for string options
 - rename the prompt from "Barebox image filename" to "Image filename"
 - slightly improve the Config.in help text.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/barebox/Config.in
boot/barebox/barebox.mk

index a2d800ea458d443dffe98f8d5e4530c46753f5c6..07295861590030d127069988d2f78467e672e259 100644 (file)
@@ -97,6 +97,16 @@ config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
          A space-separated list of configuration fragment files,
          that will be merged to the main Barebox configuration file.
 
+config BR2_TARGET_BAREBOX_IMAGE_FILE
+       string "Image filename"
+       help
+         Name of the generated barebox image, which will be copied to
+         the images directory.
+
+         If left empty, defaults to:
+         - barebox.bin for barebox versions older than 2012.10.
+         - barebox-flash-image for later versions.
+
 config BR2_TARGET_BAREBOX_BAREBOXENV
        bool "bareboxenv tool in target"
        help
index 7715dafe61861c6020e9cb2cadaf42a2e4df1701..dbda9a142341064b792d6b8b501dad205056fd1f 100644 (file)
@@ -91,8 +91,12 @@ define BAREBOX_BUILD_CMDS
        $(BAREBOX_BUILD_CUSTOM_ENV)
 endef
 
+BAREBOX_IMAGE_FILE = $(call qstrip,$(BR2_TARGET_BAREBOX_IMAGE_FILE))
+
 define BAREBOX_INSTALL_IMAGES_CMDS
-       if test -h $(@D)/barebox-flash-image ; then \
+       if test -n "$(BAREBOX_IMAGE_FILE)"; then \
+               cp -L $(@D)/$(BAREBOX_IMAGE_FILE) $(BINARIES_DIR) ; \
+       elif test -h $(@D)/barebox-flash-image ; then \
                cp -L $(@D)/barebox-flash-image $(BINARIES_DIR)/barebox.bin ; \
        else \
                cp $(@D)/barebox.bin $(BINARIES_DIR);\