package/dillo: renumber patches
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 27 Aug 2020 16:27:45 +0000 (18:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 27 Aug 2020 21:19:07 +0000 (23:19 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dillo/0001-usr-local-include.patch [new file with mode: 0644]
package/dillo/0002-Fix-openssl-detection.patch [new file with mode: 0644]
package/dillo/0002-usr-local-include.patch [deleted file]
package/dillo/0003-Fix-openssl-detection.patch [deleted file]
package/dillo/0003-Support-OpenSSL-1.1.0.patch [new file with mode: 0644]
package/dillo/0004-Support-OpenSSL-1.1.0.patch [deleted file]

diff --git a/package/dillo/0001-usr-local-include.patch b/package/dillo/0001-usr-local-include.patch
new file mode 100644 (file)
index 0000000..0c3fed2
--- /dev/null
@@ -0,0 +1,27 @@
+Do not add (possibly poisoned) /usr/local/include and /usr/local/lib
+to gcc and ld search paths in configure.
+
+With BR2_COMPILER_PARANOID_UNSAFE_PATH enabled, poisoned paths result
+in hard errors, failing affected configure tests.
+
+Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -57,16 +57,6 @@
+ AC_TYPE_INT32_T
+ AC_TYPE_UINT32_T
+-dnl --------------------------------------
+-dnl Check whether to add /usr/local or not
+-dnl (this is somewhat a religious problem)
+-dnl --------------------------------------
+-dnl
+-if test "`$CPP -v < /dev/null 2>&1 | grep '/usr/local/include' 2>&1`" = ""; then
+-  CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-  LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-fi
+-
+ dnl ------------------------------------
+ dnl Check for socket libs (AIX, Solaris)
+ dnl ------------------------------------
diff --git a/package/dillo/0002-Fix-openssl-detection.patch b/package/dillo/0002-Fix-openssl-detection.patch
new file mode 100644 (file)
index 0000000..6e5f1d0
--- /dev/null
@@ -0,0 +1,29 @@
+From 96dde9dedf806256cdc6cbf5cacbd5c8d74e6288 Mon Sep 17 00:00:00 2001
+From: Jonathan Kimmitt <jrrk2@cam.ac.uk>
+Date: Thu, 9 Jan 2020 22:01:42 +0100
+Subject: [PATCH] Fix openssl detection
+
+SSL_library_init is now a define, use OPENSSL_init_ssl instead.
+
+Signed-off-by: Jonathan Kimmitt <jrrk2@cam.ac.uk>
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 66b5e9f..206fd53 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -276,7 +276,7 @@ if test "x$enable_ssl" = "xyes"; then
+   if test "x$ssl_ok" = "xyes"; then
+     old_libs="$LIBS"
+-    AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
++    AC_CHECK_LIB(ssl, OPENSSL_init_ssl, ssl_ok=yes, ssl_ok=no, -lcrypto)
+     LIBS="$old_libs"
+   fi
+-- 
+2.24.1
+
diff --git a/package/dillo/0002-usr-local-include.patch b/package/dillo/0002-usr-local-include.patch
deleted file mode 100644 (file)
index 0c3fed2..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-Do not add (possibly poisoned) /usr/local/include and /usr/local/lib
-to gcc and ld search paths in configure.
-
-With BR2_COMPILER_PARANOID_UNSAFE_PATH enabled, poisoned paths result
-in hard errors, failing affected configure tests.
-
-Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -57,16 +57,6 @@
- AC_TYPE_INT32_T
- AC_TYPE_UINT32_T
--dnl --------------------------------------
--dnl Check whether to add /usr/local or not
--dnl (this is somewhat a religious problem)
--dnl --------------------------------------
--dnl
--if test "`$CPP -v < /dev/null 2>&1 | grep '/usr/local/include' 2>&1`" = ""; then
--  CPPFLAGS="$CPPFLAGS -I/usr/local/include"
--  LDFLAGS="$LDFLAGS -L/usr/local/lib"
--fi
--
- dnl ------------------------------------
- dnl Check for socket libs (AIX, Solaris)
- dnl ------------------------------------
diff --git a/package/dillo/0003-Fix-openssl-detection.patch b/package/dillo/0003-Fix-openssl-detection.patch
deleted file mode 100644 (file)
index 6e5f1d0..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From 96dde9dedf806256cdc6cbf5cacbd5c8d74e6288 Mon Sep 17 00:00:00 2001
-From: Jonathan Kimmitt <jrrk2@cam.ac.uk>
-Date: Thu, 9 Jan 2020 22:01:42 +0100
-Subject: [PATCH] Fix openssl detection
-
-SSL_library_init is now a define, use OPENSSL_init_ssl instead.
-
-Signed-off-by: Jonathan Kimmitt <jrrk2@cam.ac.uk>
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 66b5e9f..206fd53 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -276,7 +276,7 @@ if test "x$enable_ssl" = "xyes"; then
-   if test "x$ssl_ok" = "xyes"; then
-     old_libs="$LIBS"
--    AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
-+    AC_CHECK_LIB(ssl, OPENSSL_init_ssl, ssl_ok=yes, ssl_ok=no, -lcrypto)
-     LIBS="$old_libs"
-   fi
--- 
-2.24.1
-
diff --git a/package/dillo/0003-Support-OpenSSL-1.1.0.patch b/package/dillo/0003-Support-OpenSSL-1.1.0.patch
new file mode 100644 (file)
index 0000000..87b9d0d
--- /dev/null
@@ -0,0 +1,33 @@
+From ff44d8b2d5211a502afdb3e612dae0e8133b5124 Mon Sep 17 00:00:00 2001
+From: Johannes Hofmann <Johannes.Hofmann@gmx.de>
+Date: Thu, 9 Jan 2020 22:07:15 +0100
+Subject: [PATCH] Support OpenSSL 1.1.0
+
+taken-from: pkgsrc (Ryo ONODERA)
+submitted-by: Jun Ebihara <jun@soum.co.jp>
+
+Upstream: https://hg.dillo.org/dillo/rev/b171b8610400
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ dpi/https.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/dpi/https.c b/dpi/https.c
+index 766b3af..025cfc4 100644
+--- a/dpi/https.c
++++ b/dpi/https.c
+@@ -476,7 +476,11 @@ static int handle_certificate_problem(SSL * ssl_connection)
+       case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
+          /*Either self signed and untrusted*/
+          /*Extract CN from certificate name information*/
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+          if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
++#else
++         if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
++#endif
+             strcpy(buf, "(no CN given)");
+          } else {
+             char *cn_end;
+-- 
+2.24.1
+
diff --git a/package/dillo/0004-Support-OpenSSL-1.1.0.patch b/package/dillo/0004-Support-OpenSSL-1.1.0.patch
deleted file mode 100644 (file)
index 87b9d0d..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From ff44d8b2d5211a502afdb3e612dae0e8133b5124 Mon Sep 17 00:00:00 2001
-From: Johannes Hofmann <Johannes.Hofmann@gmx.de>
-Date: Thu, 9 Jan 2020 22:07:15 +0100
-Subject: [PATCH] Support OpenSSL 1.1.0
-
-taken-from: pkgsrc (Ryo ONODERA)
-submitted-by: Jun Ebihara <jun@soum.co.jp>
-
-Upstream: https://hg.dillo.org/dillo/rev/b171b8610400
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- dpi/https.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/dpi/https.c b/dpi/https.c
-index 766b3af..025cfc4 100644
---- a/dpi/https.c
-+++ b/dpi/https.c
-@@ -476,7 +476,11 @@ static int handle_certificate_problem(SSL * ssl_connection)
-       case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
-          /*Either self signed and untrusted*/
-          /*Extract CN from certificate name information*/
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-          if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
-+#else
-+         if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
-+#endif
-             strcpy(buf, "(no CN given)");
-          } else {
-             char *cn_end;
--- 
-2.24.1
-