gpsd: use <pkg>_INSTALL_INIT_SYSV mechanism
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:07 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 21:56:11 +0000 (22:56 +0100)
Also makes the installation of the init script unconditional.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gpsd/gpsd.mk

index 7dc27e8b2688dbed60bf26795e359c9b2cd47e2d..5092b38a49793c24b976a5c3f1a8b1c5916c6c9d 100644 (file)
@@ -206,10 +206,11 @@ define GPSD_INSTALL_TARGET_CMDS
                $(SCONS) \
                $(GPSD_SCONS_OPTS) \
                install)
-       if [ ! -f $(TARGET_DIR)/etc/init.d/S50gpsd ]; then \
-               $(INSTALL) -m 0755 -D package/gpsd/S50gpsd $(TARGET_DIR)/etc/init.d/S50gpsd; \
-               $(SED) 's,^DEVICES=.*,DEVICES=$(BR2_PACKAGE_GPSD_DEVICES),' $(TARGET_DIR)/etc/init.d/S50gpsd; \
-       fi
+endef
+
+define GPSD_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/gpsd/S50gpsd $(TARGET_DIR)/etc/init.d/S50gpsd
+       $(SED) 's,^DEVICES=.*,DEVICES=$(BR2_PACKAGE_GPSD_DEVICES),' $(TARGET_DIR)/etc/init.d/S50gpsd
 endef
 
 define GPSD_INSTALL_STAGING_CMDS