package/matchbox: make match-startup-monitor a real package
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:26 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 20:58:16 +0000 (22:58 +0200)
Currently, matchbox-startup-monitor is missing a Kconfig entry, but is
so far solely a build-time dependency of matchbox-panel.

So, make it a real package, and only build-depend on it when enabled.
Fix the condition to build-depend on it.

To keep the existing behaviour, default to 'y' when startup-notification
is enabled.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Reviewed-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/Config.in
package/matchbox/matchbox-panel/matchbox-panel.mk
package/matchbox/matchbox-startup-monitor/Config.in [new file with mode: 0644]

index 9b27d4dc87b222c5638f1813aabc51d72f2be4e9..2f9b73dbd03c89f6bb8b4c3bddf5825a4209d460 100644 (file)
@@ -26,5 +26,6 @@ source "package/matchbox/matchbox-desktop/Config.in"
 source "package/matchbox/matchbox-common/Config.in"
 source "package/matchbox/matchbox-fakekey/Config.in"
 source "package/matchbox/matchbox-keyboard/Config.in"
+source "package/matchbox/matchbox-startup-monitor/Config.in"
 
 endif
index d3efed9fca8d1cc5a454b25a996f182267cfbfa8..f7d699bdac6904aad4481c13266f4d36d60127ac 100644 (file)
@@ -13,9 +13,9 @@ MATCHBOX_PANEL_LICENSE_FILES = COPYING
 MATCHBOX_PANEL_DEPENDENCIES = matchbox-lib
 MATCHBOX_PANEL_CONF_OPTS = --enable-expat
 
-ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
+ifeq ($(BR2_PACKAGE_MATCHBOX_STARTUP_MONITOR),y)
 MATCHBOX_PANEL_CONF_OPTS += --enable-startup-notification
-MATCHBOX_PANEL_DEPENDENCIES += startup-notification matchbox-startup-monitor
+MATCHBOX_PANEL_DEPENDENCIES += matchbox-startup-monitor
 else
 MATCHBOX_PANEL_CONF_OPTS += --disable-startup-notification
 endif
diff --git a/package/matchbox/matchbox-startup-monitor/Config.in b/package/matchbox/matchbox-startup-monitor/Config.in
new file mode 100644 (file)
index 0000000..95af5fc
--- /dev/null
@@ -0,0 +1,3 @@
+config BR2_PACKAGE_MATCHBOX_STARTUP_MONITOR
+       bool
+       default y if BR2_PACKAGE_STARTUP_NOTIFICATION