package/perl-mail-dkim: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Apr 2015 10:17:20 +0000 (12:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 11:43:45 +0000 (13:43 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-mail-dkim/Config.in [new file with mode: 0644]
package/perl-mail-dkim/perl-mail-dkim.hash [new file with mode: 0644]
package/perl-mail-dkim/perl-mail-dkim.mk [new file with mode: 0644]

index b80eb19af2cd23474913f484e3537bdc6b8d88b8..f75815565a7a75a96b6ae37e8a5952735026b729 100644 (file)
@@ -525,6 +525,7 @@ menu "Perl libraries/modules"
        source "package/perl-json-tiny/Config.in"
        source "package/perl-libwww/Config.in"
        source "package/perl-lwp-mediatypes/Config.in"
+       source "package/perl-mail-dkim/Config.in"
        source "package/perl-mailtools/Config.in"
        source "package/perl-mime-base64/Config.in"
        source "package/perl-mojolicious/Config.in"
diff --git a/package/perl-mail-dkim/Config.in b/package/perl-mail-dkim/Config.in
new file mode 100644 (file)
index 0000000..3db54f3
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_PERL_MAIL_DKIM
+       bool "perl-mail-dkim"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_PERL_CRYPT_OPENSSL_RSA
+       select BR2_PACKAGE_PERL_MAILTOOLS
+       select BR2_PACKAGE_PERL_NET_DNS
+       help
+         Signs/verifies Internet mail with DKIM/DomainKey signatures
+
+         https://metacpan.org/release/Mail-DKIM
+
+comment "perl-mail-dkim needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-mail-dkim/perl-mail-dkim.hash b/package/perl-mail-dkim/perl-mail-dkim.hash
new file mode 100644 (file)
index 0000000..b6bb545
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    9ceb8a0397aff83928e7a9760b1b190f Mail-DKIM-0.40.tar.gz
+sha256 3c5ea0c3a2028a5a2c3b64bbcd6bd9de6a5fa5ee4e16046dd8875c4796aaa6f1 Mail-DKIM-0.40.tar.gz
diff --git a/package/perl-mail-dkim/perl-mail-dkim.mk b/package/perl-mail-dkim/perl-mail-dkim.mk
new file mode 100644 (file)
index 0000000..7f00299
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# perl-mail-dkim
+#
+################################################################################
+
+PERL_MAIL_DKIM_VERSION = 0.40
+PERL_MAIL_DKIM_SOURCE = Mail-DKIM-$(PERL_MAIL_DKIM_VERSION).tar.gz
+PERL_MAIL_DKIM_SITE = $(BR2_CPAN_MIRROR)/authors/id/J/JA/JASLONG
+PERL_MAIL_DKIM_DEPENDENCIES = perl perl-crypt-openssl-rsa perl-mailtools perl-net-dns
+
+$(eval $(perl-package))