package/tor: add optional support for libcap
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 4 Dec 2016 10:37:22 +0000 (11:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 14:36:36 +0000 (15:36 +0100)
- without libcap
$ host/usr/bin/x86_64-linux-readelf -a target/usr/bin/tor | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libevent-2.0.so.5]
 0x0000000000000001 (NEEDED)             Shared library: [libssl.so.1.0.0]
 0x0000000000000001 (NEEDED)             Shared library: [libcrypto.so.1.0.0]
 0x0000000000000001 (NEEDED)             Shared library: [libz.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.0]

- with libcap
$ host/usr/bin/x86_64-linux-readelf -a target/usr/bin/tor | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libevent-2.0.so.5]
 0x0000000000000001 (NEEDED)             Shared library: [libssl.so.1.0.0]
 0x0000000000000001 (NEEDED)             Shared library: [libcrypto.so.1.0.0]
 0x0000000000000001 (NEEDED)             Shared library: [libz.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libcap.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.0]

The tor configure script has no option to en-/disable libcap support.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tor/tor.mk

index 6a622cf0ef6d6eb9adfc09ed6da4e605d1e2fcbf..a3249092ca4a637cd1c06e231c4a1861f8580808 100644 (file)
@@ -26,6 +26,10 @@ TOR_CONF_OPTS += \
        --enable-static-zlib
 endif
 
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+TOR_DEPENDENCIES += libcap
+endif
+
 ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
 TOR_CONF_OPTS += --enable-seccomp
 TOR_DEPENDENCIES += libseccomp