package/dieharder: fix build with gcc 10
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 19 Aug 2020 16:34:18 +0000 (18:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 19 Aug 2020 21:28:34 +0000 (23:28 +0200)
Disable -fno-common with dieharder, there is more than 100 variables to
fix and upstream seems dead.

Fixes:
 - http://autobuild.buildroot.org/results/ba70d111cd1f2029a193a88af3b44daf6ef27786

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/dieharder/dieharder.mk

index c3eee6455389debe8c553b99dbc3032b900bd2e8..cbf28922fd6aa0a6d259c660823c6f3869543d10 100644 (file)
@@ -36,4 +36,9 @@ endif
 # parallel build fail, disable it
 DIEHARDER_MAKE = $(MAKE1)
 
+# Too many fixes needed to build with -fno-common which is default since gcc 10
+ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_10),y)
+DIEHARDER_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fcommon"
+endif
+
 $(eval $(autotools-package))