stunnel: use the <pkg>_INSTALL_INIT_SYSV mechanism
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:17:58 +0000 (15:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 21:46:13 +0000 (22:46 +0100)
Since the existing STUNNEL_INSTALL_CONF_SCRIPT hook no longer installs
the init script, we rename it to STUNNEL_INSTALL_CONF.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/stunnel/stunnel.mk

index dc5626165c70cdb542887fc4d5b1f7fa25803d72..ac2963e03d28947332f7b5d81d553e3b6c8ce6eb 100644 (file)
@@ -18,14 +18,17 @@ else
 STUNNEL_CONF_OPTS += --disable-systemd
 endif
 
-define STUNNEL_INSTALL_CONF_SCRIPT
-       $(INSTALL) -m 0755 -D package/stunnel/S50stunnel $(TARGET_DIR)/etc/init.d/S50stunnel
+define STUNNEL_INSTALL_CONF
        [ -f $(TARGET_DIR)/etc/stunnel/stunnel.conf ] || \
                $(INSTALL) -m 0644 -D $(@D)/tools/stunnel.conf \
                        $(TARGET_DIR)/etc/stunnel/stunnel.conf
        rm -f $(TARGET_DIR)/etc/stunnel/stunnel.conf-sample
 endef
 
-STUNNEL_POST_INSTALL_TARGET_HOOKS += STUNNEL_INSTALL_CONF_SCRIPT
+STUNNEL_POST_INSTALL_TARGET_HOOKS += STUNNEL_INSTALL_CONF
+
+define STUNNEL_INSTALL_INIT_SYSV
+       $(INSTALL) -m 0755 -D package/stunnel/S50stunnel $(TARGET_DIR)/etc/init.d/S50stunnel
+endef
 
 $(eval $(autotools-package))