jansson: needs math library
authorBaruch Siach <baruch@tkos.co.il>
Sun, 20 Apr 2014 07:22:39 +0000 (10:22 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 08:54:50 +0000 (10:54 +0200)
libjansson.so doesn't list libm in its NEEDED header. Fixes the following
nftables config time failure:

.../usr/lib/libjansson.so.4: undefined reference to `__isnan'
.../usr/lib/libjansson.so.4: undefined reference to `__isinf'

Fixes:
http://autobuild.buildroot.net/results/152/1525d7a3e1d1fcf35858962251c0b69a5e1b64db/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/jansson/jansson.mk

index 6ead0ec10c9a17c4b65a30a8150021333e1d6d6c..d51e7097cd8ca606052d8637430d8494dee5ea61 100644 (file)
@@ -9,5 +9,6 @@ JANSSON_SITE = http://www.digip.org/jansson/releases
 JANSSON_LICENSE = MIT
 JANSSON_LICENSE_FILES = LICENSE
 JANSSON_INSTALL_STAGING = YES
+JANSSON_CONF_ENV = LIBS="-lm"
 
 $(eval $(autotools-package))