usb_modeswitch_data: add patch to fix parallel installation
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Aug 2012 17:25:08 +0000 (19:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Aug 2012 17:25:08 +0000 (19:25 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/usb_modeswitch_data/usb_modeswitch_data-fix-parallel-install.patch [new file with mode: 0644]

diff --git a/package/usb_modeswitch_data/usb_modeswitch_data-fix-parallel-install.patch b/package/usb_modeswitch_data/usb_modeswitch_data-fix-parallel-install.patch
new file mode 100644 (file)
index 0000000..ba30499
--- /dev/null
@@ -0,0 +1,17 @@
+Properly create the directory before creating it so that parallel
+install work fine.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -22,6 +22,7 @@
+       install -D --mode=644 40-usb_modeswitch.rules $(RULESDIR)/40-usb_modeswitch.rules
+ db-install:
++      install -d $(PREFIX)/share/usb_modeswitch
+       install --mode=644 -t $(PREFIX)/share/usb_modeswitch ./usb_modeswitch.d/*
+ db-install-packed: