libostree: make sure libavahi-client is built
authorMarcus Folkesson <marcus.folkesson@gmail.com>
Thu, 21 Dec 2017 23:19:32 +0000 (00:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 28 Dec 2017 21:55:42 +0000 (22:55 +0100)
Avahi support also needs libavahi-client, which is built by avahi if avahi-daemon
and dbus is selected.

Fixes:
http://autobuild.buildroot.net/results/1edfb60add17945eabc557e1dbfb08a0ba466df9/

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
[Thomas: drop dependency on dbus, since libostree only needs avahi.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libostree/libostree.mk

index 612c284870abe559885fe04427acfeee3c86f166..26f173c1ba8ffc9bf1cf7f094f26350efe4f0eb7 100644 (file)
@@ -27,7 +27,11 @@ else
 LIBOSTREE_CONF_OPTS += --without-openssl
 endif
 
-ifeq ($(BR2_PACKAGE_AVAHI),y)
+# Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
+# and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
+# option yet, use the avahi-daemon and dbus config symbols to check for
+# libavahi-client.
+ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
 LIBOSTREE_CONF_OPTS += --with-avahi
 LIBOSTREE_DEPENDENCIES += avahi
 else