package/swupdate: don't require website for services
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 29 Aug 2021 02:46:26 +0000 (20:46 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 14:11:46 +0000 (16:11 +0200)
The swupdate services do not depend on
BR2_PACKAGE_SWUPDATE_INSTALL_WEBSITE, so install them unconditionally.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/swupdate/swupdate.mk

index 42008cddd751333c8a0f53c438fca64b9aa84d1b..f4a398ac8e0a8b04a8ad011ff63a11592e667898 100644 (file)
@@ -213,7 +213,6 @@ $(error No Swupdate configuration file specified, check your BR2_PACKAGE_SWUPDAT
 endif
 endif
 
-ifeq ($(BR2_PACKAGE_SWUPDATE_INSTALL_WEBSITE),y)
 define SWUPDATE_INSTALL_COMMON
        mkdir -p $(TARGET_DIR)/etc/swupdate/conf.d \
                $(TARGET_DIR)/usr/lib/swupdate/conf.d
@@ -230,6 +229,5 @@ define SWUPDATE_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 755 package/swupdate/S80swupdate \
                $(TARGET_DIR)/etc/init.d/S80swupdate
 endef
-endif
 
 $(eval $(kconfig-package))