libtomcrypt: new package
authorFrancois Perrad <fperrad@gmail.com>
Sun, 10 Apr 2016 14:55:25 +0000 (16:55 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 28 Apr 2016 17:41:27 +0000 (19:41 +0200)
[Peter: fix building without wchar]
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libtomcrypt/Config.in [new file with mode: 0644]
package/libtomcrypt/libtomcrypt.hash [new file with mode: 0644]
package/libtomcrypt/libtomcrypt.mk [new file with mode: 0644]

index e645dfe2c5c6abe8e1d70854d025261b97509c08..c7743a23bda299362bf5b446372e3654a9593cf7 100644 (file)
@@ -848,6 +848,7 @@ menu "Crypto"
        source "package/libsodium/Config.in"
        source "package/libssh/Config.in"
        source "package/libssh2/Config.in"
+       source "package/libtomcrypt/Config.in"
        source "package/libuecc/Config.in"
        source "package/mbedtls/Config.in"
        source "package/nettle/Config.in"
diff --git a/package/libtomcrypt/Config.in b/package/libtomcrypt/Config.in
new file mode 100644 (file)
index 0000000..6678b30
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBTOMCRYPT
+       bool "libtomcrypt"
+       select BR2_PACKAGE_LIBTOMMATH
+       help
+         LibTomCrypt is a fairly comprehensive, modular and portable
+         cryptographic toolkit that provides developers with a vast array
+         of well known published block ciphers, one-way hash functions,
+         chaining modes, pseudo-random number generators, public key
+         cryptography and a plethora of other routines.
+
+         http://www.libtom.net
diff --git a/package/libtomcrypt/libtomcrypt.hash b/package/libtomcrypt/libtomcrypt.hash
new file mode 100644 (file)
index 0000000..562016d
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  e33b47d77a495091c8703175a25c8228aff043140b2554c08a3c3cd71f79d116  crypt-1.17.tar.bz2
diff --git a/package/libtomcrypt/libtomcrypt.mk b/package/libtomcrypt/libtomcrypt.mk
new file mode 100644 (file)
index 0000000..53dbfd5
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# libtomcrypt
+#
+################################################################################
+
+LIBTOMCRYPT_VERSION = 1.17
+LIBTOMCRYPT_SITE = https://github.com/libtom/libtomcrypt/releases/download/$(LIBTOMCRYPT_VERSION)
+LIBTOMCRYPT_SOURCE = crypt-$(LIBTOMCRYPT_VERSION).tar.bz2
+LIBTOMCRYPT_LICENSE = WTFPL
+LIBTOMCRYPT_LICENSE_FILES = LICENSE
+LIBTOMCRYPT_INSTALL_STAGING = YES
+LIBTOMCRYPT_INSTALL_TARGET = NO # only static library
+LIBTOMCRYPT_DEPENDENCIES = libtommath
+
+LIBTOMCRYPT_CFLAGS = -I./src/headers $(TARGET_CFLAGS) -DLTC_SOURCE -DLTM_DESC \
+       $(if $(BR2_USE_WCHAR),,-DLTC_NO_WCHAR)
+
+define LIBTOMCRYPT_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) CFLAGS="$(LIBTOMCRYPT_CFLAGS)"
+endef
+
+define LIBTOMCRYPT_INSTALL_STAGING_CMDS
+       $(MAKE) -C $(@D) DESTDIR="$(STAGING_DIR)" NODOCS=1 INSTALL_USER=$(shell id -u) INSTALL_GROUP=$(shell id -g) install
+endef
+
+$(eval $(generic-package))