pkg-infra: remove self-dependency from host packages
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 14 Jul 2012 20:31:19 +0000 (22:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Jul 2012 10:36:23 +0000 (12:36 +0200)
When HOST_XXX_DEPENDENCIES are derived automatically from
XXX_DEPENDENCIES, a self-dependency is created if host-xxx is a dependency
of xxx.  This was the case for miniperl.

Filter out the self-dependency.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-autotargets.mk
package/pkg-cmaketargets.mk
package/pkg-gentargets.mk

index c9887c2e1f97aa30e399e259fc89b63cd2d248d3..d31230dd7d9636d289a41b363b7d8f0084b39aa6 100644 (file)
@@ -201,7 +201,7 @@ endef
 # This must be repeated from GENTARGETS_INNER, otherwise we get an empty
 # _DEPENDENCIES if _AUTORECONF is YES.  Also filter the result of _AUTORECONF
 # away from the non-host rule
-$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool,\
+$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool $(1),\
     $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
 
 
index 371ab11c76bd77c47bb272494899cfc4295a9166..b405df50541ca7ed39f26d6cdd9b85d2bc937bd0 100644 (file)
@@ -98,7 +98,7 @@ endif
 
 # This must be repeated from GENTARGETS_INNER, otherwise we only get
 # host-cmake in _DEPENDENCIES because of the following line
-$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+$(2)_DEPENDENCIES ?= $(filter-out $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
 
 $(2)_DEPENDENCIES += host-cmake
 
index 1c9b458074d10f82a75f2118a193c6c2e327087b..5da9cdc7040abcad6bf1765c461e98759b132e70 100644 (file)
@@ -245,7 +245,7 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
 endif
 endif
 
-$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+$(2)_DEPENDENCIES ?= $(filter-out $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
 
 $(2)_INSTALL_STAGING           ?= NO
 $(2)_INSTALL_IMAGES            ?= NO