dnsmasq: static linking with lua doesn't need -ldl
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Jun 2014 08:46:41 +0000 (10:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Jun 2014 08:46:41 +0000 (10:46 +0200)
Fixes http://autobuild.buildroot.net/results/77e/77e4123a3ddc934efedf4b09adc2436421ee70b3/

liblua only uses libdl when dynamic linking is used, and certain toolchains
(E.G.  bfin) doesn't provide a libdl - So only link against it if it is
needed.

At the same time change it pass the library in LIBS instead of LDFLAGS so it
ends up at the end of the linker cmdline.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dnsmasq/dnsmasq.mk

index dd15994aafc387ecb52f3c9d4f069ace0226654e..71d2f3029000cba7c84eec97eb3d42c9fd4dde65 100644 (file)
@@ -55,7 +55,11 @@ endif
 
 ifeq ($(BR2_PACKAGE_DNSMASQ_LUA),y)
        DNSMASQ_DEPENDENCIES += lua
-       DNSMASQ_MAKE_OPT += LDFLAGS+="-ldl"
+
+# liblua uses dlopen when dynamically linked
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+       DNSMASQ_MAKE_OPT += LIBS="-ldl"
+endif
 
 define DNSMASQ_ENABLE_LUA
        $(SED) 's/lua5.1/lua/g' $(DNSMASQ_DIR)/Makefile