linux: fix depmod location after move to host-kmod
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Sep 2013 19:54:59 +0000 (21:54 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Sep 2013 19:56:35 +0000 (21:56 +0200)
The host-kmod version of depmod gets installed into HOST_DIR/sbin, so
adjust the path we use to refer to it in linux.mk

Reported-by: Ryan Coe <bluemrp9@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 8508a542426e6d36a94cd11fe381d166fef82ab9..649d06b6d39bb12a34ced21937fae91162f2bb80 100644 (file)
@@ -47,7 +47,7 @@ LINUX_MAKE_FLAGS = \
        ARCH=$(KERNEL_ARCH) \
        INSTALL_MOD_PATH=$(TARGET_DIR) \
        CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
-       DEPMOD=$(HOST_DIR)/usr/sbin/depmod
+       DEPMOD=$(HOST_DIR)/sbin/depmod
 
 # Get the real Linux version, which tells us where kernel modules are
 # going to be installed in the target filesystem.