package/efl/libevas: explicitly disable GL/GLES2 support
authorRomain Naour <romain.naour@openwide.fr>
Sat, 14 Feb 2015 22:28:43 +0000 (23:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Feb 2015 15:50:59 +0000 (16:50 +0100)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libevas/libevas.mk

index 30d9f7c74a79ccf39d90a9e69d5a51180b2fa2fa..486805089e3a8f5d4335eaf032732c406ff9122c 100644 (file)
@@ -107,16 +107,25 @@ LIBEVAS_CONF_ENV += \
        GL_EET_LIBS='-leet'
 endif
 
+# libevas OpenGL flavor
 ifeq ($(BR2_PACKAGE_LIBEVAS_GL),y)
 LIBEVAS_DEPENDENCIES += mesa3d libeet
 endif
 
 ifeq ($(BR2_PACKAGE_LIBEVAS_GLES_SGX),y)
 LIBEVAS_CONF_OPTS += --enable-gl-flavor-gles --enable-gles-variety-sgx
+else
+LIBEVAS_CONF_OPTS += --disable-gles-variety-sgx
 endif
 
 ifeq ($(BR2_PACKAGE_LIBEVAS_GLES_S3C6410),y)
 LIBEVAS_CONF_OPTS += --enable-gl-flavor-gles --enable-gles-variety-s3c6410
+else
+LIBEVAS_CONF_OPTS += --disable-gles-variety-s3c6410
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEVAS_GLES_SGX)$(BR2_PACKAGE_LIBEVAS_GLES_S3C6410),)
+LIBEVAS_CONF_OPTS += --disable-gl-flavor-gles
 endif
 
 # code options