package/kf5/kf5-kcoreaddons: don't treat ld warnings as errors
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Wed, 18 Dec 2019 16:19:57 +0000 (17:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Dec 2019 22:22:29 +0000 (23:22 +0100)
Microblaze ld emits warnings like:
'
FDE encoding in
CMakeFiles/KF5CoreAddons.dir/KF5CoreAddons_autogen/mocs_compilation.cpp.o(.eh_frame)
prevents .eh_frame_hdr table being created
'
Since '-Wl,--fatal-warnings' is passed by default, build fails, so don't
treat warnings as errors by appending "-Wl,--no-fatal-warnings" to
CMAKE_SHARED_LINKER_FLAGS that is previously defined in package
dependency kf5-extra-cmake-modules.

Fixes:
http://autobuild.buildroot.net/results/f19/f198c86930535c50393e17fc7a70fb4f27b096ee/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/kf5/kf5-kcoreaddons/kf5-kcoreaddons.mk

index 164bad1225c4b4a953ac52f32985f3cce0fdf970..5b3e9acd90ca1c98d42e09dc694e4a5bdf9a285b 100644 (file)
@@ -21,4 +21,9 @@ endif
 
 KF5_KCOREADDONS_CONF_OPTS = -DCMAKE_CXX_FLAGS="$(KF5_KCOREADDONS_CXXFLAGS)"
 
+ifeq ($(BR2_microblaze),y)
+# Microblaze ld emits warnings, make warnings not to be treated as errors
+KF5_KCOREADDONS_CONF_OPTS = -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--no-fatal-warnings"
+endif
+
 $(eval $(cmake-package))