package/c-periphery: bump version to 2.2.1
authorJoris Offouga <offougajoris@gmail.com>
Mon, 1 Jun 2020 07:48:40 +0000 (09:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 2 Jun 2020 21:19:29 +0000 (23:19 +0200)
Since commit "cmake: add cmake build support"
(https://github.com/vsergeev/c-periphery/commit/952e1e906a5d65b78932128af24b7dbb8cce2e9dvsergeev/c-periphery@d0a973c),
c-periphery implement cmake build, so use cmake-package instead of
generic-package. Due to this, it now builds a shared library, so we
drop the INSTALL_TARGET = NO.

The hash of the license file is updated due to an update in the
copyright year:

  - Copyright (c) 2014-2019 vsergeev / Ivan (Vanya) A. Sergeev
  + Copyright (c) 2014-2020 vsergeev / Ivan (Vanya) A. Sergeev

Signed-off-by: Joris Offouga <offougajoris@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/c-periphery/c-periphery.hash
package/c-periphery/c-periphery.mk

index 244f8f60f1fcaeebfd5277de82b538da670f06fe..a1842612b97f1bec55f34fc2d8dec99dbd813bbb 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 1c455c42b26818d199ac227cd19714f265623e15d363fdfdf47a2416a4165654  c-periphery-2.1.0.tar.gz
-sha256 e7b9464cb8511f19ddb40f9cf52fe86b3dfe38b2faed9d7bbc3d5707677ffbe3  LICENSE
+sha256 7afa2a18e0bf0ccb09b832017c61a411a94cff648a9a57f9f9068bcf14a5d972  c-periphery-2.2.1.tar.gz
+sha256 7121a0a2ba36ed9388be2f1a916f0e3584d8e49cc7888fbcfcf83bab2a8bebef  LICENSE
index bb50434efaaa6e48821fe2d8666856ebd661fe63..3869fc1111b1530a5d59f6490ee1414877c034c7 100644 (file)
@@ -4,24 +4,10 @@
 #
 ################################################################################
 
-C_PERIPHERY_VERSION = 2.1.0
+C_PERIPHERY_VERSION = 2.2.1
 C_PERIPHERY_SITE = $(call github,vsergeev,c-periphery,v$(C_PERIPHERY_VERSION))
 C_PERIPHERY_INSTALL_STAGING = YES
-# only a static library
-C_PERIPHERY_INSTALL_TARGET = NO
 C_PERIPHERY_LICENSE = MIT
 C_PERIPHERY_LICENSE_FILES = LICENSE
 
-define C_PERIPHERY_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
-endef
-
-# There is no 'install' rule in the Makefile, so we handle things
-# manually.
-define C_PERIPHERY_INSTALL_STAGING_CMDS
-       $(INSTALL) -D -m 0644 $(@D)/periphery.a $(STAGING_DIR)/usr/lib/libc-periphery.a
-       mkdir -p $(STAGING_DIR)/usr/include/c-periphery/
-       cp -dpfr $(@D)/src/*.h $(STAGING_DIR)/usr/include/c-periphery/
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))