* Refined building of neon options
authorNigel Kukard <nkukard@lbsd.net>
Wed, 31 Dec 2008 18:22:43 +0000 (18:22 -0000)
committerNigel Kukard <nkukard@lbsd.net>
Wed, 31 Dec 2008 18:22:43 +0000 (18:22 -0000)
- Added support to build with or without zlib support

package/neon/Config.in
package/neon/neon.mk

index 1ffb61a35ab3062ab2fda221f2e58fa7bf463c55..e9050742ba5f38dc1812fbeb1dea913e41a8527a 100644 (file)
@@ -6,6 +6,13 @@ config BR2_PACKAGE_NEON
 
          http://www.webdav.org/neon/
 
+config BR2_PACKAGE_NEON_ZLIB
+       bool "ZLIB support"
+       depends on BR2_PACKAGE_NEON
+       select BR2_PACKAGE_ZLIB
+       help
+         build with ZLIB support
+
 choice
        prompt "XML Support"
        default BR2_PACKAGE_NEON_NOXML
index e92e134b6524a8315b443f2048236d4b298c3396..61cf7527e069a51fe2795fd6c9ffe39ce03588cf 100644 (file)
@@ -16,6 +16,12 @@ NEON_CONF_OPT+=--with-libxml2=yes
 NEON_CONF_OPT+=--with-expat=no
 NEON_DEPENDENCIES+=libxml2
 endif
+ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)
+NEON_CONF_OPT+=--with-zlib=$(STAGING_DIR)
+NEON_DEPENDENCIES+=zlib
+else
+NEON_CONF_OPT+=--without-zlib
+endif
 ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
 NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
 NEON_CONF_OPT+=--with-libxml2=no