package/bootstrap: bump version to 3.3.7
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 24 May 2017 15:32:39 +0000 (17:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 May 2017 13:34:03 +0000 (15:34 +0200)
Extended _EXTRACT_CMDS and _INSTALL_TARGET_CMDS to handle updated
internal zip structure:

$ unzip -l ../dl/bootstrap-3.3.1-dist.zip
Archive:  ../dl/bootstrap-3.3.1-dist.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
        0  2014-11-12 18:03   dist/
        0  2014-11-12 18:03   dist/css/
[...]

$ unzip -l ../dl/bootstrap-3.3.7-dist.zip
Archive:  ../dl/bootstrap-3.3.7-dist.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
        0  2016-07-25 15:53   bootstrap-3.3.7-dist/css/
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: better fix for the EXTRACT_CMDS, which consists in removing the
dist/ sub-directory.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bootstrap/bootstrap.hash
package/bootstrap/bootstrap.mk

index acb06b4246dda5b4475c27669e207a9f60d59669..abc09da2139e6c21d9d6e17fc23615a04792ff95 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed:
-sha256  95ca4a02aff37570660c81a87065b53ebc281c33fa86b91a6a7a650eee10678f  bootstrap-3.3.1-dist.zip
+sha256 f498a8ff2dd007e29c2074f5e4b01a9a01775c3ff3aeaf6906ea503bc5791b7b  bootstrap-3.3.7-dist.zip
index 17752ce068eaba2f5a7868c2b23f4e7e79836fdd..33161f53ae7e4f87d583bdba48f1e01e1399779a 100644 (file)
@@ -4,23 +4,25 @@
 #
 ################################################################################
 
-BOOTSTRAP_VERSION = 3.3.1
+BOOTSTRAP_VERSION = 3.3.7
 BOOTSTRAP_SITE = https://github.com/twbs/bootstrap/releases/download/v$(BOOTSTRAP_VERSION)
 BOOTSTRAP_SOURCE = bootstrap-$(BOOTSTRAP_VERSION)-dist.zip
 BOOTSTRAP_LICENSE = MIT
 
 define BOOTSTRAP_EXTRACT_CMDS
        $(UNZIP) $(DL_DIR)/$(BOOTSTRAP_SOURCE) -d $(@D)
+       mv $(@D)/bootstrap-$(BOOTSTRAP_VERSION)-dist/* $(@D)/
+       rmdir $(@D)/bootstrap-$(BOOTSTRAP_VERSION)-dist
 endef
 
 define BOOTSTRAP_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 0644 -D $(@D)/dist/css/bootstrap-theme.min.css \
+       $(INSTALL) -m 0644 -D $(@D)/css/bootstrap-theme.min.css \
                $(TARGET_DIR)/var/www/bootstrap/css/bootstrap-theme.min.css
-       $(INSTALL) -m 0644 -D $(@D)/dist/css/bootstrap.min.css \
+       $(INSTALL) -m 0644 -D $(@D)/css/bootstrap.min.css \
                $(TARGET_DIR)/var/www/bootstrap/css/bootstrap.min.css
-       $(INSTALL) -m 0644 -D $(@D)/dist/js/bootstrap.min.js \
+       $(INSTALL) -m 0644 -D $(@D)/js/bootstrap.min.js \
                $(TARGET_DIR)/var/www/bootstrap/js/bootstrap.min.js
-       cp -r $(@D)/dist/fonts $(TARGET_DIR)/var/www/bootstrap/
+       cp -r $(@D)/fonts $(TARGET_DIR)/var/www/bootstrap/
 endef
 
 $(eval $(generic-package))