openssl: disable assembly for ARMv7M
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 22 Jun 2016 13:47:28 +0000 (10:47 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 22 Jun 2016 14:59:23 +0000 (16:59 +0200)
It requires interwork and v7M is thumb-only. Fixes:
http://autobuild.buildroot.net/results/55d/55dc9d6826defd2c9048c2991019d4d573d34af4/

[Peter: use R2_ARM_CPU_HAS_ARM for logic]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openssl/openssl.mk

index 2368aa913c24e908563dcc0fdbde535ec50b4ad1..e34868e842a5e8b85b6c6d1f8d6b309e585cfc2c 100644 (file)
@@ -34,7 +34,8 @@ OPENSSL_DEPENDENCIES += ocf-linux
 endif
 
 # Some architectures are optimized in OpenSSL
-ifeq ($(ARCH),arm)
+# Doesn't work for thumb-only (Cortex-M?)
+ifeq ($(BR2_ARM_CPU_HAS_ARM),y)
 OPENSSL_TARGET_ARCH = armv4
 endif
 ifeq ($(ARCH),aarch64)