ctorrent: build with ssl support if available
authorKelvin Cheung <keguang.zhang@gmail.com>
Mon, 31 Aug 2009 05:23:59 +0000 (07:23 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 31 Aug 2009 05:23:59 +0000 (07:23 +0200)
Closes #557

Build with openssl support if that is enabled.

Signed-off-by: Kelvin Cheung <keguang.zhang@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/ctorrent/ctorrent.mk

diff --git a/CHANGES b/CHANGES
index a0e39f7ec248c8f085a5a914cc0cf3e6d2110da8..917572424fc0bbfc29c3a1787751156cbdfe691d 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,6 +3,7 @@
        Issues resolved (http://bugs.uclibc.org):
 
        #529: util-linux doesn't find headers and include libs correctly
+       #557: Build ctorrent with SSL support if available
 
 2009.08-rc3, Released August 26th, 2009:
 
index 256088180f25965aa17ef3a50265ac056688e68a..aa22153155fc622081e77066d1d9cab9f44a5231 100644 (file)
@@ -6,6 +6,12 @@
 CTORRENT_VERSION:=dnh3.3.2
 CTORRENT_SOURCE:=ctorrent-$(CTORRENT_VERSION).tar.gz
 CTORRENT_SITE:=http://www.rahul.net/dholmes/ctorrent/
-CTORRENT_CONF_OPT:=--with-ssl=no
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+CTORRENT_CONF_OPT+=--with-ssl=yes
+CTORRENT_DEPENDENCIES+=openssl
+else
+CTORRENT_CONF_OPT+=--with-ssl=no
+endif
 
 $(eval $(call AUTOTARGETS,package,ctorrent))