package/triggerhappy: bump to latest commit to fix runtime issue
authorJörg Krause <joerg.krause@embedded.rocks>
Tue, 19 Jan 2016 09:51:53 +0000 (10:51 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 19 Jan 2016 21:53:59 +0000 (22:53 +0100)
Bump to latest commit to fix runtime issue with the Linux Kernel headers 4.4:
  Starting thd: Unable to parse trigger line: [..]

With version 4.4 of the Linux Kernel the input event codes are not defined in
'linux/input.h' anymore, but in a seperate header file
'linux/input-event-codes.h' leaving triggerhappys evtable_*.h header files
empty with no event codes defined.

This issue is fixed upstream by commit 7e5abc69f215678e93a6b999524981c8b40bdcd9
which also makes overwriting of the 'LINUX_INPUT_H' definition obsolet.

Tested with an internal Buildroot toolchain with Linux Kernel headers 4.4 and
an external Linaro ARM 2015.08 toolchain with Linux Kernel headers 4.0.

[Peter: add hash file]
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/triggerhappy/triggerhappy.hash [new file with mode: 0644]
package/triggerhappy/triggerhappy.mk

diff --git a/package/triggerhappy/triggerhappy.hash b/package/triggerhappy/triggerhappy.hash
new file mode 100644 (file)
index 0000000..17eefdb
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 6b01497377e522c368818c5f6c726362f42530e3dc24a01c6d77b1b4d6068308  triggerhappy-7e5abc69f215678e93a6b999524981c8b40bdcd9.tar.gz
index 3a68e5094535671437aa8212b0742f0c41a35803..5a29ca7773d8c1ef8e87a65d23e82782d70efc07 100644 (file)
@@ -4,15 +4,13 @@
 #
 ################################################################################
 
-TRIGGERHAPPY_VERSION = aac9f353a28c0f414b27ac54bbbb2292c152eedc
+TRIGGERHAPPY_VERSION = 7e5abc69f215678e93a6b999524981c8b40bdcd9
 TRIGGERHAPPY_SITE = $(call github,wertarbyte,triggerhappy,$(TRIGGERHAPPY_VERSION))
 TRIGGERHAPPY_LICENSE = GPLv3+
 TRIGGERHAPPY_LICENSE_FILES = COPYING
 
 define TRIGGERHAPPY_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) \
-               LINUX_INPUT_H=$(STAGING_DIR)/usr/include/linux/input.h \
-               -C $(@D) thd th-cmd
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) thd th-cmd
 endef
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)