leptonica: new package
authorGilles Talis <gilles.talis@gmail.com>
Sun, 19 Mar 2017 08:07:52 +0000 (09:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Mar 2017 13:57:50 +0000 (14:57 +0100)
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/leptonica/Config.in [new file with mode: 0644]
package/leptonica/leptonica.hash [new file with mode: 0644]
package/leptonica/leptonica.mk [new file with mode: 0644]

index 746a54713ae44c5d6ab8b5f89ac435f7f1969935..8802fc70c2b4c78cbff7d091b02a103d53611e7f 100644 (file)
@@ -587,6 +587,7 @@ N:  Gilles Talis <gilles.talis@gmail.com>
 F:     package/fdk-aac/
 F:     package/httping/
 F:     package/iozone/
+F:     package/leptonica/
 F:     package/ocrad/
 F:     package/webp/
 
index 52b4f3637c38ce537303b178cb0e884c607a62ba..ed480588f6bd9a19ff0ea01a463509f0a7784cba 100644 (file)
@@ -1010,6 +1010,7 @@ menu "Graphics"
        source "package/jpeg/Config.in"
        source "package/kmsxx/Config.in"
        source "package/lcms2/Config.in"
+       source "package/leptonica/Config.in"
        source "package/lesstif/Config.in"
        source "package/libart/Config.in"
        source "package/libdmtx/Config.in"
diff --git a/package/leptonica/Config.in b/package/leptonica/Config.in
new file mode 100644 (file)
index 0000000..a4053a3
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LEPTONICA
+       bool "leptonica"
+       help
+         Leptonica is a pedagogically-oriented open source site containing
+         software that is broadly useful for image processing and image
+         analysis applications.
+
+         http://www.leptonica.org/
diff --git a/package/leptonica/leptonica.hash b/package/leptonica/leptonica.hash
new file mode 100644 (file)
index 0000000..48da06b
--- /dev/null
@@ -0,0 +1,2 @@
+# locally computed hash
+sha256 746a517a47a3bd2a90bc8d581ca6464c10f30e91a60209735efe45b3778bec62  leptonica-1.74.1.tar.gz
diff --git a/package/leptonica/leptonica.mk b/package/leptonica/leptonica.mk
new file mode 100644 (file)
index 0000000..37e5219
--- /dev/null
@@ -0,0 +1,64 @@
+################################################################################
+#
+# leptonica
+#
+################################################################################
+
+LEPTONICA_VERSION = 1.74.1
+LEPTONICA_SITE = http://www.leptonica.org/source
+LEPTONICA_LICENSE = BSD-2c
+LEPTONICA_LICENSE_FILES = leptonica-license.txt
+LEPTONICA_INSTALL_STAGING = YES
+
+LEPTONICA_CONF_OPTS += --disable-programs
+
+ifeq ($(BR2_PACKAGE_GIFLIB),y)
+LEPTONICA_DEPENDENCIES += giflib
+LEPTONICA_CONF_OPTS +=  --with-giflib
+else
+LEPTONICA_CONF_OPTS +=  --without-giflib
+endif
+
+ifeq ($(BR2_PACKAGE_JPEG),y)
+LEPTONICA_DEPENDENCIES += jpeg
+LEPTONICA_CONF_OPTS += --with-jpeg
+else
+LEPTONICA_CONF_OPTS += --without-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+LEPTONICA_DEPENDENCIES += libpng
+LEPTONICA_CONF_OPTS += --with-libpng
+else
+LEPTONICA_CONF_OPTS += --without-libpng
+endif
+
+ifeq ($(BR2_PACKAGE_OPENJPEG),y)
+LEPTONICA_DEPENDENCIES += openjpeg
+LEPTONICA_CONF_OPTS += --with-libopenjpeg
+else
+LEPTONICA_CONF_OPTS += --without-libopenjpeg
+endif
+
+ifeq ($(BR2_PACKAGE_TIFF),y)
+LEPTONICA_DEPENDENCIES += tiff
+LEPTONICA_CONF_OPTS += --with-libtiff
+else
+LEPTONICA_CONF_OPTS += --without-libtiff
+endif
+
+ifeq ($(BR2_PACKAGE_WEBP),y)
+LEPTONICA_DEPENDENCIES += webp
+LEPTONICA_CONF_OPTS += --with-libwebp
+else
+LEPTONICA_CONF_OPTS += --without-libwebp
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+LEPTONICA_DEPENDENCIES += zlib
+LEPTONICA_CONF_OPTS += --with-zlib
+else
+LEPTONICA_CONF_OPTS += --without-zlib
+endif
+
+$(eval $(autotools-package))