coreutils: bump to version 8.26
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 9 Dec 2016 13:43:09 +0000 (10:43 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 9 Dec 2016 16:56:52 +0000 (17:56 +0100)
Pass on INSTALL_PROGRAM to configure since starting with version 8.26
when building natively it tries to use the self-built install to
install, and when cross-compiling it expects INSTALL_PROGRAM to point to
a real install, or otherwise fails when recursively trying to expand it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/coreutils/coreutils.hash
package/coreutils/coreutils.mk

index 38d3bb1eebcf4e8af539908f1ac0fc294370ae89..37d630bba9e93133e93c4e5f7167e562bce36bc4 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 31e67c057a5b32a582f26408c789e11c2e8d676593324849dcf5779296cdce87        coreutils-8.25.tar.xz
+sha256 155e94d748f8e2bc327c66e0cbebdb8d6ab265d2f37c3c928f7bf6c3beba9a8e        coreutils-8.26.tar.xz
index 0d7b7821a2b078eb69c4a941f7cf9a6dd9cefb5f..409089c332f9b3b1c7095d739fa7d467e1a3f1f3 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-COREUTILS_VERSION = 8.25
+COREUTILS_VERSION = 8.26
 COREUTILS_SITE = $(BR2_GNU_MIRROR)/coreutils
 COREUTILS_SOURCE = coreutils-$(COREUTILS_VERSION).tar.xz
 COREUTILS_LICENSE = GPLv3+
@@ -52,7 +52,8 @@ COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
        gl_cv_have_proc_uptime=yes \
        utils_cv_localtime_cache=no \
        PERL=missing \
-       MAKEINFO=true
+       MAKEINFO=true \
+       INSTALL_PROGRAM=$(INSTALL)
 
 COREUTILS_BIN_PROGS = cat chgrp chmod chown cp date dd df dir echo false \
        ln ls mkdir mknod mv pwd rm rmdir vdir sleep stty sync touch true \