tcping: new package
authorArnaud Rébillout <rebillout@syscom.ch>
Fri, 13 Sep 2013 07:33:58 +0000 (09:33 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 13 Sep 2013 09:23:41 +0000 (11:23 +0200)
tcping does a TCP connect to the given ip/port combination. The user can
specify a timeout in seconds. This is useful in shell scripts running in
firewalled environments. Often SYNs are just being dropped by firewalls,
thus connection establishment will be retried several times (for minutes)
until a TCP timeout is reached. With tcping it is possible to check first
if the desired port is reachable and then start connection establishment.

http://www.linuxco.de/tcping/tcping.html

[Peter: wrap help text, pass TARGET_LDFLAGS]
Signed-off-by: Arnaud Rébillout <rebillout@syscom.ch>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/tcping/Config.in [new file with mode: 0644]
package/tcping/tcping.mk [new file with mode: 0644]

index aae3296dee790a65e671370bf3d5f6b5a5a563c0..3ea4b4ecbde68f9a1de8251913688bfd52b61544 100644 (file)
@@ -858,6 +858,7 @@ source "package/squid/Config.in"
 source "package/strongswan/Config.in"
 source "package/stunnel/Config.in"
 source "package/tcpdump/Config.in"
+source "package/tcping/Config.in"
 source "package/tcpreplay/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/tftpd/Config.in"
diff --git a/package/tcping/Config.in b/package/tcping/Config.in
new file mode 100644 (file)
index 0000000..6677b58
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_TCPING
+       bool "tcping"
+       help
+         tcping does a TCP connect to the given ip/port
+         combination. The user can specify a timeout in seconds. This
+         is useful in shell scripts running in firewalled
+         environments. Often SYNs are just being dropped by
+         firewalls, thus connection establishment will be retried
+         several times (for minutes) until a TCP timeout is
+         reached. With tcping it is possible to check first if the
+         desired port is reachable and then start connection
+         establishment.
+
+         http://www.linuxco.de/tcping/tcping.html
diff --git a/package/tcping/tcping.mk b/package/tcping/tcping.mk
new file mode 100644 (file)
index 0000000..ff43490
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# tcping
+#
+################################################################################
+
+TCPING_VERSION = 1.3.5
+TCPING_SITE = http://www.linuxco.de/tcping
+TCPING_LICENSE = GPLv3+
+TCPING_LICENSE_FILES = LICENSE
+
+define TCPING_BUILD_CMDS
+       $(MAKE) CC="$(TARGET_CC)" CCFLAGS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+               -C $(@D) tcping.linux
+endef
+
+define TCPING_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/tcping $(TARGET_DIR)/usr/bin/tcping
+endef
+
+$(eval $(generic-package))