qextserialport: install QExtSerialPort header with qmake
authorArnout Vandecappelle <arnout@mind.be>
Thu, 24 Nov 2016 22:37:45 +0000 (23:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Nov 2016 16:47:32 +0000 (17:47 +0100)
Instead of manually copying the QExtSerialPort header introduced in
patch 0002, update the patch to include this header in the qmake
project file so it gets properly installed.

While we're at it, convert to a git-formatted patch.

Fixes:
http://autobuild.buildroot.net/results/818b564a6e23bcecf4afc7e53811227b08e5f4eb
http://autobuild.buildroot.net/results/0b6c2d7c63329f5e790f02ccd29f14a317eadc71
http://autobuild.buildroot.net/results/ac552b63c6fb099a136066cda421f68e639808fa

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qextserialport/0002-Create-a-main-include-file-QExtSerialPort.patch [new file with mode: 0644]
package/qextserialport/0002-main-include.patch [deleted file]
package/qextserialport/qextserialport.mk

diff --git a/package/qextserialport/0002-Create-a-main-include-file-QExtSerialPort.patch b/package/qextserialport/0002-Create-a-main-include-file-QExtSerialPort.patch
new file mode 100644 (file)
index 0000000..1f14304
--- /dev/null
@@ -0,0 +1,43 @@
+From 62fbe9c3539945df6204501b7e3ae0d51db075a3 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Thu, 24 Nov 2016 22:30:40 +0100
+Subject: [PATCH] Create a main include file QExtSerialPort
+
+This main include file will be installed in
+<QtExtSerialPort/QExtSerialPort> so that Qt applications can use this
+library by including header files in a Qt-like style.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+[Arnout: add it to qextserialport.pri so it is installed]
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
+---
+ src/QExtSerialPort     | 2 ++
+ src/qextserialport.pri | 3 ++-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+ create mode 100644 src/QExtSerialPort
+
+diff --git a/src/QExtSerialPort b/src/QExtSerialPort
+new file mode 100644
+index 0000000..a48aeea
+--- /dev/null
++++ b/src/QExtSerialPort
+@@ -0,0 +1,2 @@
++#include "qextserialport.h"
++#include "qextserialenumerator.h"
+diff --git a/src/qextserialport.pri b/src/qextserialport.pri
+index 461d56f..f8a678d 100644
+--- a/src/qextserialport.pri
++++ b/src/qextserialport.pri
+@@ -3,7 +3,8 @@ DEPENDPATH += $$PWD
+ PUBLIC_HEADERS         += $$PWD/qextserialport.h \
+                           $$PWD/qextserialenumerator.h \
+-                          $$PWD/qextserialport_global.h
++                          $$PWD/qextserialport_global.h \
++                          $$PWD/QExtSerialPort
+ HEADERS                += $$PUBLIC_HEADERS \
+                           $$PWD/qextserialport_p.h \
+-- 
+2.10.2
+
diff --git a/package/qextserialport/0002-main-include.patch b/package/qextserialport/0002-main-include.patch
deleted file mode 100644 (file)
index 27f67f6..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-Create a main include file QExtSerialPort
-
-This main include file will be installed in
-<QtExtSerialPort/QExtSerialPort> so that Qt applications can use this
-library by including header files in a Qt-like style.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: qextserialport-ef4af2a2ee3f/src/QExtSerialPort
-===================================================================
---- /dev/null
-+++ qextserialport-ef4af2a2ee3f/src/QExtSerialPort
-@@ -0,0 +1,2 @@
-+#include "qextserialport.h"
-+#include "qextserialenumerator.h"
index 3641353a3f00e0c8f3f6d3f3de5d36dd1d567ae3..62bf3b016d6753f855ea1c5ab96119c49544f68a 100644 (file)
@@ -32,7 +32,6 @@ endef
 
 define QEXTSERIALPORT_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
-       cp $(@D)/src/QExtSerialPort $(STAGING_DIR)/usr/include/QtExtSerialPort/
        cp $(@D)/qextserialport.pc $(STAGING_DIR)/usr/lib/pkgconfig/
 endef